[sapl-dev] Instalador do SAPL 2.3 funcionando 100% - novamente

Luciano De Fazio lucianodefazio em gmail.com
Terça Setembro 6 18:55:35 BRT 2011


Colegas,

Informo que detectei e corrigi uma falha na instalação do produto
libxml-2.2.6.30, componente essencial do SAPL, que não estava mais sendo
compilado no Ubuntu 10.04, através do instalador unificado.

Em decorrência da falta desse pacote, o libxstl e o libxml2-python também
deixavam de ser instalados, ocasionando diversos problemas, entre os quais:

- falha na criação automática do "container" sapl durante a instalação,
forçando a inserção manual, conforme constava na Fase 3 do documento
http://colab.interlegis.gov.br/wiki/HOWTO-InstalarSAPL23Ubuntu

- erros no módulo de proposições

Além disso, no instalador também havia outro problema, que culminava
no armazenamento da pasta /sapl/sapl_documentos dentro do arquivo Data.fs,
em vez de estar montada no SaplDocumentos.fs

Para verificar estas e outras correções, consulte o timeline do Colab:
http://colab.interlegis.gov.br/timeline

Não sei exatamente quando o problema começou, provavelmente durante
atualizações dos compiladores do Ubuntu 10.04, mas sugiro a quem instalou o
sistema recentemente que refaça as instalações, baixando novamente os
arquivos de instalação, para poder usufruir de todas as funcionalidades do
SAPL 2.3

Procedimento atualizado:
http://colab.interlegis.gov.br/wiki/HOWTO-InstalarSAPL23Ubuntu

[]'s

Luciano De Fázio
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: http://listas.interlegis.gov.br/pipermail/sapl-dev/attachments/20110906/ba267a76/attachment.htm 


Mais detalhes sobre a lista de discussão SAPL-dev