<div dir="ltr">Olá pessoal,<br><br>Assumi a administração de um portal que foi instalado<b> fora do padrão</b> Plone-4.2-UnifiedInstaller-update-1.tgz. Como desejo padronizar este ambiente como os outros, tentei fazer a migração deste ambiente copiando a base (blobstorage e filestorage) e fazendo comparações entre os arquivos buildout, quanto a eggs e versões<br><br>Procedimento realizado<br>1- Criação de um novo host e instalado plone 4.2.0 utilizando o arquivo padrão Plone-4.2-UnifiedInstaller-update-1.tgz<br><br>2- Cópia do blobstorage e filestorage do ambiente atual que está fora do padrão para o desejado.<br><br>3- Comparação entre os arquivos buildout. Não houve necessidade de acrescentar nenhuma egg neste ambiente novo por já estar similar e não conter nenhum produto adicional. Mas foi observado que a versão do plone é diferente, como apresentado no arquivo em anexo (versao_atual.png e versao_desejada.png)<br><br>4- Erro gerado após aceitar atualização. Obs: Arquivo completo em anexo (relatorio_de_atualizacao.rtf)<br><br><div>TypeError: ("'ExtensionClass.ExtensionClass' object is not iterable", <function Provides at 0x2999938>, (<class 'Products.ATContentTypes.content.folder.ATFolder'>, <class 'Products.Carousel.interfaces.ICarouselFolder'>))</div><div>End of upgrade path, migration has finished</div><div>The upgrade path did NOT reach current version</div><div>Migration has failed</div><div>Dry run selected, transaction aborted</div><br>Obs: A ambiente atual está com o ZODB separado, por isso encaminhei o buildout dele. O ambiente desejado também terá o ZODB separado, mas num primeiro momento farei a instalação tudo num host só.<br><br>Grato desde já a atenção de todos.</div>