[plonegov-br] Problema ao rodar buildout para ambiente de produção: Plone 4.3.18 + Portal Padrão 2.1.2.dev0

Pedro Pacheco pedro.pacheco em insa.gov.br
Sexta Março 6 16:34:30 -03 2020


Boa tarde pessoal, 

Estou com dificuldade para rodar o buildout para ambiente em produção: (production.cfg). Estou usando, Portal Padrão 2.1.2.dev0, Plone 4.3.18, no ubuntu 18.04 (pacotes/depedências já instalados). O erro: internal error occurred due to a bug in either zc.buildout or in/ a OSError: [Errno 12] Cannot allocate memory é que está dando no final do loop. Entretanto, consigo rodar o buildout.cfg p/ ambiente de desenvolvimento, configurando da seguinte maneira abaixo: 

git clone [ https://github.com/plonegovbr/portal.buildout.git | https://github.com/plonegovbr/portal.buildout.git ] #master 
vim buildout.cfg # config p/ desenvolvimento. # Usamos aqui a documentação para config do buildout.cfg : [ https://identidade-digital-de-governo-plone.readthedocs.io/en/latest/desenvolvimento/ | https://identidade-digital-de-governo-plone.readthedocs.io/en/latest/desenvolvimento/ ] 
virtualenv py27 
source py27/bin/activate 
bin/pip install -r requirements.txt 
bin/buildout annotate 
bin/buildout 
su plone 
bin/instance start 
bin/instance status 


Obs.: E fazendo da mesma maneira como desmostrado acima, para ambiente de produção, alterando somente o buildout.cfg apontando para os dados que está nessa documentação do buildout.cfg: [ https://identidade-digital-de-governo-plone.readthedocs.io/en/latest/producao/ | https://identidade-digital-de-governo-plone.readthedocs.io/en/latest/producao/ ] não funciona. Alguém já passou por isso, tem algum luz? 

Grato desde já! 





Att, 

Pedro Vitor Cerqueira Pacheco 
Analista de Infraestrutura Sênior (Campina Tec) 
Outsourcing: Instituto Nacional do Semiárido - INSA 
Av. Francisco Lopes de Almeida, S/N – Bairro Serrotão - CEP: 58429-970 
Cidade: Campina Grande (PB). 
Tel: +55 (83) 3315-6417 
E-mail: pedro.pacheco em insa.gov.br 



De: "Joao Pedro dos Santos Thome" <joao.thome em unila.edu.br> 
Para: "Comunidade Plone no Governo" <plonegov-br em listas.interlegis.gov.br> 
Enviadas: Terça-feira, 10 de dezembro de 2019 15:42:42 
Assunto: [plonegov-br] Atualização Plone no Portal Padrão 1.5.3 

Boa tarde a todos. 

Estou tentando atualizar a versão do Plone no meu servidor da versão 4.3.18 pra 4.3.19, mas estou tendo alguns problemas com incompatibilidade de versões dos eggs, alguém que esteja usando o Portal Padrão na versão 1.5.3 conseguiu realizar esse update? 
Aproveitando o tópico, alguém saberia informar se essa versão antiga do Portal Padrão irá receber alguma atualização? 


Att., 

João Pedro dos Santos Thomé | Técnico em Tecnologia da Informação 

-- 
Comunidade Plone no Governo 
Site: http://www.softwarelivre.gov.br/plone 
Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr 
Histórico: http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br 
Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br 
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/plonegov-br/attachments/20200306/61e9b08b/attachment.html>


Mais detalhes sobre a lista de discussão PloneGov-BR