[plonegov-br] [problemas com importlib-metadata]

Alexandre Chagas alexandre.acs em gmail.com
Quinta Janeiro 16 16:57:20 BRST 2020


Boa tarde pessoal,

estou com um problema no pacote importlib-metadata:

* Recebi duas máquinas Linux (Debian 9), totalmente cruas.

- Atualizei ambas as máquinas:
$ sudo apt update && sudo apt upgrade -y
$ sudo apt install -y build-essential libssl-dev libxml2-dev libxslt1-dev
libbz2-dev zlib1g-dev python-setuptools python-dev python-virtualenv
libjpeg62-turbo-dev libreadline-gplv2-dev python-imaging python-pip wv
poppler-utils git

- Instalei o Plone 4.3.18
- Atualizei o versions.cfg
https://github.com/plonegovbr/portalpadrao.release/blob/master/2.1.1/versions.cfg

- Atualizei o eggs buildout
   brasil.gov.portal

Resultado:

* Maquina Um: Tudo ocorreu perfeitamente, portal no ar (IDG 2.1.1).

* Maquina Dois (Praticamente Clone da Um): Problemas no pacote
importlib-metadata. Com a seguinte mensagem de erro:

<<<Getting required 'importlib-metadata<2,>=0.23'
  required by argcomplete 1.11.1.
We have no distributions for importlib-metadata that satisfies
'importlib-metadata<2,>=0.23'.
Getting distribution for 'importlib-metadata<2,>=0.23'.
Running easy_install:
"/opt/Plone-4.3.18-boloarte/Python-2.7/bin/python" "-c" "import sys;
sys.path[0:0] =
['/opt/Plone-4.3.18-boloarte/buildout-cache/eggs/setuptools-27.3.0-py2.7.egg'];
from setuptools.command.easy_install import main; main()" "-mZUNxd"
"/opt/Plone-4.3.18-boloarte/buildout-cache/eggs/tmpgRkWcT" "-q"
"/opt/Plone-4.3.18-boloarte/buildout-cache/downloads/dist/importlib_metadata-1.4.0.tar.gz"
path=/opt/Plone-4.3.18-boloarte/buildout-cache/eggs/setuptools-27.3.0-py2.7.egg

/opt/Plone-4.3.18-boloarte/Python-2.7/lib/python2.7/distutils/dist.py:267:
UserWarning: Unknown distribution option: 'use_scm_version'
  warnings.warn(msg)
warning: no previously-included files found matching '.gitignore'
no previously-included directories found matching 'build'
no previously-included directories found matching '.tox'
warning: install_lib: 'build/lib' does not exist -- no Python modules to
install

zip_safe flag not set; analyzing archive contents...
Installing importlib-metadata 1.4.0
Caused installation of a distribution:
UNKNOWN 0.0.0
with a different project name.
Installing importlib-metadata 1.4.0
Caused installation of a distribution:
UNKNOWN 0.0.0
with a different version.
Path /opt/Plone-4.3.18-boloarte/buildout-cache/eggs/UNKNOWN-0.0.0-py2.7.egg
unexpectedly already exists.
Maybe a buildout running in parallel has added it. We will accept it.
If this contains a wrong package, please remove it yourself.
Got None.
Picked: UNKNOWN = 0.0.0
Version and requirements information containing importlib-metadata:
  Requirement of argcomplete: importlib-metadata<2,>=0.23
While:
  Installing client1.
Error: There is a version conflict.
We already have: UNKNOWN 0.0.0
but argcomplete 1.11.1 requires 'importlib-metadata<2,>=0.23'.>>>

*****

Depois disso:

Instalei todas as versões (da 0.23 a 1.4.0) executando o comando "pip
install importlib-metadata"

"nada"

No buildout.cfg em [versions] Acrescentei todas as versões possíveis para
cada compilação.

De nada adiantou. O Estranho é, pq uma máquina que é espelho da outra, uma
funciona e a outra não.

Alguém já passou por isso?

Desde já, sou grato por qualquer help.

Alexandre Chagas

-- 
*Alexandre Chagas*
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/plonegov-br/attachments/20200116/5a1122c0/attachment.html>


Mais detalhes sobre a lista de discussão PloneGov-BR