[plonegov-br] Como usar o plone.app.multilingual no plonegovBR

felipelc felipelc em lncc.br
Terça Julho 30 11:58:03 BRT 2019


Em 2019-07-29 21:40, Clayton escreveu:
>> Estou fazendo correto?
> Não
>
> Não instale complementos via "pip install", esta errado tudo tem que
> via buildout.
>
> No final do seu arquivo crie um a seção [versions], e rode o comando
> "bin/buildout - N" :
>
> [buildout]
> extends =
>      development.cfg
>
> eggs =
>      plone.app.multilingual
>
> [remotes]
> plonegovbr = https://github.com/plonegovbr [23]
> collective = https://github.com/collective [24]
> plone = https://github.com/plone [25]
> simplesconsultoria = https://github.com/simplesconsultoria [26]
>
> [versions]
> plone.app.multilingual = 2.0.4
>
> Em seg, 29 de jul de 2019 às 15:42, felipelc <felipelc em lncc.br [27]>
> escreveu:
>
>> Em 2019-07-29 18:36, Clayton escreveu:
>> > Felipe,
>> >
>> > Na documentação [1] informa que as versões 2.x são
>> compatíveis
>> > com o Plone 4.x, então você tem que pina a versão 2.0.4 [2] no
>> seu
>> > buildout.
>> >
>> > [1] https://pypi.org/project/plone.app.multilingual/ [1] [5]
>> > [2] https://pypi.org/project/plone.app.multilingual/2.0.4/ [2]
>> [6]
>> >
>> > --
>> > Clayton
>> >
>> > Em seg, 29 de jul de 2019 às 14:54, felipelc <felipelc em lncc.br
>> [3] [7]>
>> > escreveu:
>> >
>> >> Prezados boa tarde.
>> >>
>> >> Como faço para usar o plone.app.multilinguagem no plonegovBR
>> >> (portal
>> >> padrão)?
>> >> Eu tentei via buildout porém da o erro:
>> >> Error: The requirement (Products.CMFPlone>=5.2rc4) is not
>> allowed
>> >> by
>> >> your [versions] constraint (4.3.18)
>> >> Gostaria de saber se, e como posso usá-lo.
>> >>
>> >> Desde já agradeço.
>> >>
>> >> Att,
>> >>
>> >> Felipe
>> >> --
>> >> Comunidade Plone no Governo
>> >> Site: http://www.softwarelivre.gov.br/plone [4] [1]
>> >> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr [5] [2]
>> >> Histórico:
>> >>
>> >
>> >
>>
> 
> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>> [6]
>> >> [3]
>> >> Lista:
>> >> https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>> [7] [4]
>> >
>> >
>> > Links:
>> > ------
>> > [1] http://www.softwarelivre.gov.br/plone [8]
>> > [2] http://colab.interlegis.leg.br/wiki/PloneGovBr [9]
>> > [3]
>> >
>> >
>>
> 
> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>> [10]
>> > [4] https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>> [11]
>> > [5] https://pypi.org/project/plone.app.multilingual/ [12]
>> > [6] https://pypi.org/project/plone.app.multilingual/2.0.4/ [13]
>> > [7] mailto:felipelc em lncc.br [14]
>>
>> Entendi, eu executo "pip install plone.app.multilingual==2.0.4".
>> Esse é meu buildout, eu fiz desta forma, e depois executo o
>> "bin/buildout" mas porém recebo o erro: Error: "The requirement
>> (Products.CMFPlone>=5.2rc4) is not allowed by your [versions]
>> constraint (4.3.18)"
>>
>> [buildout]
>> extends =
>>      development.cfg
>>
>> eggs =
>>      plone.multilingual
>>      plone.app,multilingual
>>
>> [remotes]
>> plonegovbr = https://github.com/plonegovbr [15]
>> collective = https://github.com/collective [16]
>> plone = https://github.com/plone [17]
>> simplesconsultoria = https://github.com/simplesconsultoria [18]
>>
>> Estou fazendo correto?
>>
>> --
>> Comunidade Plone no Governo
>> Site: http://www.softwarelivre.gov.br/plone [19]
>> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr [20]
>> Histórico:
>>
> 
> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>> [21]
>> Lista:
>> https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br [22]
>
>
> Links:
> ------
> [1] https://pypi.org/project/plone.app.multilingual/
> [2] https://pypi.org/project/plone.app.multilingual/2.0.4/
> [3] mailto:felipelc em lncc.br
> [4] http://www.softwarelivre.gov.br/plone
> [5] http://colab.interlegis.leg.br/wiki/PloneGovBr
> [6]
> 
> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
> [7] https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
> [8] http://www.softwarelivre.gov.br/plone
> [9] http://colab.interlegis.leg.br/wiki/PloneGovBr
> [10]
> 
> http://colab.interlegis.leg.br/search/?type=thread&amp;order=latest&amp;list=plonegov-br
> [11] https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
> [12] https://pypi.org/project/plone.app.multilingual/
> [13] https://pypi.org/project/plone.app.multilingual/2.0.4/
> [14] mailto:felipelc em lncc.br
> [15] https://github.com/plonegovbr
> [16] https://github.com/collective
> [17] https://github.com/plone
> [18] https://github.com/simplesconsultoria
> [19] http://www.softwarelivre.gov.br/plone
> [20] http://colab.interlegis.leg.br/wiki/PloneGovBr
> [21]
> 
> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
> [22] https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
> [23] https://github.com/plonegovbr
> [24] https://github.com/collective
> [25] https://github.com/plone
> [26] https://github.com/simplesconsultoria
> [27] mailto:felipelc em lncc.br

Bom dia, muito obrigado eu consegui instalar, usando o buildout porém 
os idiomas ou bandeiras não aparecem no topo do portal.
Como faço?

Att,

Felipe




Mais detalhes sobre a lista de discussão PloneGov-BR