[plonegov-br] Como usar o plone.app.multilingual no plonegovBR

Clayton claytonc.sousa em gmail.com
Segunda Julho 29 18:40:24 BRT 2019


> Estou fazendo correto?
Não

Não instale complementos via "pip install", esta errado tudo tem que via
buildout.

No final do seu arquivo crie um a seção [versions], e rode o comando
"bin/buildout - N" :

[buildout]
extends =
     development.cfg

eggs =
     plone.app.multilingual

[remotes]
plonegovbr = https://github.com/plonegovbr
collective = https://github.com/collective
plone = https://github.com/plone
simplesconsultoria = https://github.com/simplesconsultoria

[versions]
plone.app.multilingual = 2.0.4

Em seg, 29 de jul de 2019 às 15:42, felipelc <felipelc em lncc.br> escreveu:

> Em 2019-07-29 18:36, Clayton escreveu:
> > Felipe,
> >
> > Na documentação [1] informa que as versões 2.x são compatíveis
> > com o Plone 4.x, então você tem que pina a versão 2.0.4 [2] no seu
> > buildout.
> >
> > [1] https://pypi.org/project/plone.app.multilingual/ [5]
> > [2] https://pypi.org/project/plone.app.multilingual/2.0.4/ [6]
> >
> > --
> > Clayton
> >
> > Em seg, 29 de jul de 2019 às 14:54, felipelc <felipelc em lncc.br [7]>
> > escreveu:
> >
> >> Prezados boa tarde.
> >>
> >> Como faço para usar o plone.app.multilinguagem no plonegovBR
> >> (portal
> >> padrão)?
> >> Eu tentei via buildout porém da o erro:
> >> Error: The requirement (Products.CMFPlone>=5.2rc4) is not allowed
> >> by
> >> your [versions] constraint (4.3.18)
> >> Gostaria de saber se, e como posso usá-lo.
> >>
> >> Desde já agradeço.
> >>
> >> Att,
> >>
> >> Felipe
> >> --
> >> Comunidade Plone no Governo
> >> Site: http://www.softwarelivre.gov.br/plone [1]
> >> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr [2]
> >> Histórico:
> >>
> >
> >
> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
> >> [3]
> >> Lista:
> >> https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br [4]
> >
> >
> > Links:
> > ------
> > [1] http://www.softwarelivre.gov.br/plone
> > [2] http://colab.interlegis.leg.br/wiki/PloneGovBr
> > [3]
> >
> >
> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
> > [4] https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
> > [5] https://pypi.org/project/plone.app.multilingual/
> > [6] https://pypi.org/project/plone.app.multilingual/2.0.4/
> > [7] mailto:felipelc em lncc.br
>
>
> Entendi, eu executo "pip install plone.app.multilingual==2.0.4".
> Esse é meu buildout, eu fiz desta forma, e depois executo o
> "bin/buildout" mas porém recebo o erro: Error: "The requirement
> ('Products.CMFPlone>=5.2rc4') is not allowed by your [versions]
> constraint (4.3.18)"
>
> [buildout]
> extends =
>      development.cfg
>
> eggs =
>      plone.multilingual
>      plone.app,multilingual
>
>
>
> [remotes]
> plonegovbr = https://github.com/plonegovbr
> collective = https://github.com/collective
> plone = https://github.com/plone
> simplesconsultoria = https://github.com/simplesconsultoria
>
> Estou fazendo correto?
>
> --
> Comunidade Plone no Governo
> Site: http://www.softwarelivre.gov.br/plone
> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
> Histórico:
> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/plonegov-br/attachments/20190729/93ec94df/attachment.html>


Mais detalhes sobre a lista de discussão PloneGov-BR