[plonegov-br] Erro na atualização da versão 1.0.3-1.5.3

Denis Francis Assunçao da Silva denis.silva em cgu.gov.br
Quinta Novembro 29 22:11:12 BRST 2018


Prezados,

Estou tentando atualizar o site para a versão 1.5.3, porém, estou obtendo o erro abaixo.
Aparentemente o erro ocorre por causa de um item duplicado no vocabulário. Porém, não sei como eliminá-lo.
Alguém tem alguma ideia?

Att.,
Denis

Configurações atualmente ativas
4309
Última configuração disponível
4320
Relatório de atualização
Dry run selected.
Starting the migration from version: 4309
There are unresolved or circular dependencies. Graphviz diagram:: digraph dependencies {"caching_policy_mgr" -> "toolset"; "typeinfo" -> "toolset"; "tinymce_settings" -> "componentregistry"; "transmogrifier" -> "toolset"; "archetypes-various" -> "componentregistry"; "pleonformgen" -> "toolset"; "pleonformgen" -> "propertiestool"; "pleonformgen" -> "typeinfo"; "atcttool" -> "catalog"; "atcttool" -> "componentregistry"; "actions" -> "componentregistry"; "skins" -> "componentregistry"; "cssregistry" -> "skins"; "cssregistry" -> "toolset"; "cssregistry" -> "componentregistry"; "Doormat-postInstall" -> "Doormat-QI-dependencies"; "collective.z3cform.datetimewidget_various";"factorytool" -> "componentregistry"; "factorytool" -> "typeinfo"; "archetypetool" -> "archetypes-various"; "placeful_workflow" -> "typeinfo"; "placeful_workflow" -> "workflow"; "base-content" -> "typeinfo"; "import-intid-util" -> "toolset"; "controlpanel" -> "actions"; "controlpanel" -> "componentregistry"; "placeful_marker" -> "workflow"; "action-icons" -> "componentregistry"; "componentregistry" -> "toolset"; "content" -> "typeinfo"; "sc.social.like.install";"plone.app.tiles_default";"mimetypes-registry-various" -> "componentregistry"; "sharing" -> "rolemap"; "plone.app.event-catalog" -> "plone.app.registry"; "referenceablebehavior-various" -> "toolset"; "reference_catalog" -> "toolset"; "viewlets" -> "componentregistry"; "plone.app.registry" -> "componentregistry"; "plone.app.registry" -> "toolset"; "propertiestool" -> "componentregistry"; "various" -> "toolset"; "portlets" -> "componentregistry"; "portlets" -> "content"; "collective.nitf";"toolset";"plone-final" -> "portlets"; "plone-final" -> "rolemap"; "plone-final" -> "tinymce_settings"; "plone-final" -> "cssregistry"; "plone-final" -> "jsregistry"; "plone-final" -> "viewlets"; "plone-final" -> "controlpanel"; "plone-final" -> "propertiestool"; "plone-final" -> "workflow"; "plone.app.blocks_default";"ploneopenid-various";"update-workflow-rolemap" -> "workflow"; "plone.app.caching";"collective.z3cform.datetimewidget";"uid_catalog" -> "toolset"; "workflow" -> "toolset"; "jquerytools-various" -> "cssregistry"; "collective.polls";"contentrules" -> "componentregistry"; "contentrules" -> "content"; "contentrules" -> "workflow"; "catalog" -> "toolset"; "Products.Doormat" -> "types"; "import-relations-utils" -> "toolset"; "cmfeditions_various" -> "toolset"; "cmfeditions_various" -> "typeinfo"; "difftool" -> "toolset"; "difftool" -> "componentregistry"; "plone-content" -> "plone-final"; "content_type_registry" -> "componentregistry"; "properties";"plonepas" -> "componentregistry"; "plonepas" -> "controlpanel"; "plonepas" -> "memberdata-properties"; "plonepas" -> "rolemap"; "cookie_authentication" -> "toolset"; "tinymce_various" -> "componentregistry"; "browserlayer" -> "componentregistry"; "plone-difftool";"languagetool" -> "toolset"; "plone_outputfilters_various" -> "componentregistry"; "memberdata-properties" -> "componentregistry"; "plonetheme.sunburst-various" -> "actions"; "plone.app.versioningbehavior";"collective.js.jqueryui" -> "cssregistry"; "collective.js.jqueryui" -> "jsregistry"; "collective.js.jqueryui" -> "plone.app.registry"; "plone.restapi";"sc.embedder-portal_transforms" -> "plone-final"; "mailhost" -> "componentregistry"; "repositorytool" -> "toolset"; "repositorytool" -> "typeinfo"; "repositorytool" -> "cmfeditions_various"; "rolemap";"various-calendar" -> "toolset"; "jsregistry" -> "skins"; "jsregistry" -> "toolset"; "jsregistry" -> "componentregistry"; "portal-transforms-various" -> "componentregistry"; "intid-register-content" -> "catalog"; "intid-register-content" -> "import-intid-util"; "setup_site" -> "typeinfo"; "plone.app.theming" -> "toolset"; "Doormat-Update-RoleMappings" -> "Doormat-QI-dependencies"; "Doormat-postInstall" [color=red,style=filled]; "Products.Doormat" [color=red,style=filled]; "Doormat-Update-RoleMappings" [color=red,style=filled]; }
Role / permission map imported.
Archetype tool imported.
Upgrade aborted. Error:
Traceback (most recent call last):
  File "/backup/portalcgu.buildout/eggs/Products.CMFPlone-4.3.18-py2.7.egg/Products/CMFPlone/MigrationTool.py", line 285, in upgrade
    step['step'].doStep(setup)
  File "/backup/portalcgu.buildout/eggs/Products.GenericSetup-1.8.9-py2.7.egg/Products/GenericSetup/upgrade.py", line 166, in doStep
    self.handler(tool)
  File "/backup/portalcgu.buildout/eggs/plone.app.upgrade-1.4.5-py2.7.egg/plone/app/upgrade/v43/final.py", line 57, in improveSyndication
    loadMigrationProfile(context, 'profile-plone.app.upgrade.v43:to435')
  File "/backup/portalcgu.buildout/eggs/plone.app.upgrade-1.4.5-py2.7.egg/plone/app/upgrade/utils.py", line 180, in loadMigrationProfile
    context.runAllImportStepsFromProfile(profile, purge_old=False)
  File "/backup/portalcgu.buildout/eggs/Products.GenericSetup-1.8.9-py2.7.egg/Products/GenericSetup/tool.py", line 388, in runAllImportStepsFromProfile
    dependency_strategy=dependency_strategy)
  File "/backup/portalcgu.buildout/eggs/Products.GenericSetup-1.8.9-py2.7.egg/Products/GenericSetup/tool.py", line 1433, in _runImportStepsFromContext
    message = self._doRunImportStep(step, context)
  File "/backup/portalcgu.buildout/eggs/Products.GenericSetup-1.8.9-py2.7.egg/Products/GenericSetup/tool.py", line 1245, in _doRunImportStep
    return handler(context)
  File "/backup/portalcgu.buildout/eggs/plone.app.registry-1.2.5-py2.7.egg/plone/app/registry/exportimport/handler.py", line 73, in importRegistry
    importer.importDocument(body)
  File "/backup/portalcgu.buildout/eggs/plone.app.registry-1.2.5-py2.7.egg/plone/app/registry/exportimport/handler.py", line 121, in importDocument
    self.importRecords(node)
  File "/backup/portalcgu.buildout/eggs/plone.app.registry-1.2.5-py2.7.egg/plone/app/registry/exportimport/handler.py", line 334, in importRecords
    self.context.registerInterface(interface, omit=tuple(omit), prefix=prefix)
  File "/backup/portalcgu.buildout/eggs/plone.registry-1.0.5-py2.7.egg/plone/registry/registry.py", line 117, in registerInterface
    bound_field = persistent_field.bind(existing_record)
  File "/backup/portalcgu.buildout/eggs/zope.schema-4.2.2-py2.7.egg/zope/schema/_field.py", line 471, in bind
    clone.value_type = clone.value_type.bind(object)
  File "/backup/portalcgu.buildout/eggs/plone.registry-1.0.5-py2.7.egg/plone/registry/field.py", line 286, in bind
    clone._vocabulary = vr.get(object, self.vocabularyName)
  File "/backup/portalcgu.buildout/eggs/Zope2-2.13.28-py2.7.egg/Zope2/App/schema.py", line 33, in get
    return factory(context)
  File "/backup/portalcgu.buildout/eggs/plone.app.vocabularies-2.1.25-py2.7.egg/plone/app/vocabularies/syndication.py", line 63, in __call__
    return SimpleVocabulary(items)
  File "/backup/portalcgu.buildout/eggs/zope.schema-4.2.2-py2.7.egg/zope/schema/vocabulary.py", line 65, in __init__
    'term values must be unique: %s' % repr(term.value))
ValueError: term values must be unique: '2cd35e995ba74f8ea567261bfc7748e3'
End of upgrade path, main migration has finished.
The upgrade path did NOT reach current version.
Migration has failed
Dry run selected, transaction aborted
Versão
·         Plone 4.3.18
·         Zope 2.13.28
·         Python 2.7.5 (default, Jul 13 2018, 13:06:57) [GCC 4.8.5 20150623 (Red Hat 4.8.5-28)]

Esta mensagem, incluindo quaisquer anexos, é de acesso restrito e destina-se, exclusivamente, à pessoa ou entidade para a qual foi endereçada. Se você a recebeu indevidamente, por favor, elimine-a e informe o equívoco ao emitente imediatamente. O uso não autorizado do conteúdo da mensagem ou anexos é proibido e sujeita o infrator às penalidades cabíveis.
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/plonegov-br/attachments/20181130/39f787ce/attachment.html>


Mais detalhes sobre a lista de discussão PloneGov-BR