[plonegov-br] [ANN] collective.cover ganha suporte para o Plone 5.1

Héctor Velarde hector em simplesconsultoria.com.br
Sexta Agosto 24 10:06:03 BRT 2018


É com imenso prazer que venho aqui anunciar a disponibilidade do 
collective.cover 2.0b1, a primeira versão compatível com o Plone 4.3 e o 
Plone 5.1.

O trabalho começado ha vários anos finalmente rendeu frutos. Queremos 
agradecer a Universidade Estadual de Maringá (UEM) pelo apoio para fazer 
este release uma realidade.

Se você quer testar esta nova versão e está atualizando duma anterior, 
não esqueça de ler cuidadosamente a documentação e adicionar o extra 
[relations] para evitar surpresas.

Como é sabido, o collective.cover é um pacote estável que vem sendo 
utilizado nos portais IDG ha mais de 5 anos. A nova versão ainda tem 
alguns problema de usabilidade no Plone 5.1 que pretendemos solucionar 
no futuro próximo.

Mais informação:

* https://pypi.org/project/collective.cover/2.0b1/
* https://github.com/collective/collective.cover
* problemas conhecidos no Plone 5.1: 
https://github.com/collective/collective.cover/issues?q=is%3Aissue+is%3Aopen+label%3A%22plone+5%22

O que segue?

Nos próximos messes vamos continuar trabalhando nas seguinte frentes:

* processamento de recursos estáticos usando o webpack 
(https://webpack.js.org/) para acelerar a evolução do pacote
* evitar registrar os recursos estáticos nos registries do Plone (eu 
tenho uma opinião forte nesse sentido e queremos testar uma ideia que 
vai simplificar as atualizações)
* rescrever a IU usando o Vue.js
* usar o Swiper no tile de carrossel (http://idangero.us/swiper/)
* continua adicionando melhorias, consertando bugs e limpando o pacote

Por favor nos ajudem testando o complemento; feedback e ajuda são muito 
bem-vindos.

Atenciosamente,
-- 
Héctor Velarde



Mais detalhes sobre a lista de discussão PloneGov-BR