[plonegov-br] serviço de plone 3.6 no início do linux e systemd

Juan Gomez (Txonta) juantxonta em gmail.com
Domingo Novembro 26 16:48:42 BRST 2017


Hola.
Não consigo obter o meu plone.service para trabalhar em 
/etc/systemd/system. No meu ubuntu local.
Xa o fiz no systemv mas aqui ainda não consegí.
Seguí este tutorial: 
https://docs.plone.org/3/en/manage/deploying/production/restarts.html
a parte que se refere ao systemd.
A mensagem de erro:        -$ systemctl status plone.service

     ● plone.service - Plone content management system
        Loaded: loaded (/etc/systemd/system/plone.service; enabled; 
vendor preset: enabled)
        Active: failed (Result: exit-code) since dom 2017-11-26 19:18:13 
CET; 10s ago
       Process: 3998 ExecStart=/var/www/plone/zinstance/bin/plonectl 
start (code=exited, status=0/SUCCESS)
      Main PID: 4001 (code=exited, status=1/FAILURE)

     nov 26 19:16:21 juan-ubuntu systemd[1]: Starting Plone content 
management system...
     nov 26 19:16:25 juan-ubuntu plonectl[3998]: instance: . daemon 
process started, pid=4002
     nov 26 19:16:25 juan-ubuntu systemd[1]: Started Plone content 
management system.
     nov 26 19:18:13 juan-ubuntu systemd[1]: plone.service: Main process 
exited, code=exited, status=1/FAILURE
     nov 26 19:18:13 juan-ubuntu systemd[1]: plone.service: Unit entered 
failed state.
     nov 26 19:18:13 juan-ubuntu systemd[1]: plone.service: Failed with 
result 'exit-code'.

Eu sei que agora é aconselhável usar o complemento supervisord, mas 
prefiro evitar a instalação de outro plugin para esse problema, também 
porque em breve terei de migrar toda a instalação para o plone 5.
As permissões de plone.service:       -$ ls -l 
/etc/systemd/system/plone.service
     -rwxr-xr-x 1 root root 230 nov 26 19:15 
/etc/systemd/system/plone.service
Eu também tentei com chown root:plone e nem.
A saída no syslog
     $ tail -f /var/log/syslog
     Nov 26 19:17:01 juan-ubuntu CRON[4018]: (root) CMD (   cd / && 
run-parts --report /etc/cron.hourly)
     Nov 26 19:18:13 juan-ubuntu systemd[1]: plone.service: Main process 
exited, code=exited, status=1/FAILURE
     Nov 26 19:18:13 juan-ubuntu systemd[1]: plone.service: Unit entered 
failed state.
     Nov 26 19:18:13 juan-ubuntu systemd[1]: plone.service: Failed with 
result 'exit-code'.
     Nov 26 19:18:23 juan-ubuntu systemd[1]: Configuration file 
/etc/systemd/system/plone.service is marked executable. Please remove 
executable permission bits. Proceeding anyway.

Xa tentei muda-lo permission bit mais fica pior.
qualquer pista ou conselho agradeço.
Obrigado

Juan
PS: desculpe o meu pobre português brasileiro.

-- >  🌟 🌟 tleo.es 🌟 🌟
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/plonegov-br/attachments/20171126/96f0d7e2/attachment.html>


Mais detalhes sobre a lista de discussão PloneGov-BR