[plonegov-br] Erro ao editar página de destaque

Valdir Nascimento dos Santos valdir.santos em ifba.edu.br
Terça Janeiro 17 13:11:34 BRST 2017


Ao tentar editar páginas de destaque, o plone devolve o seguinte erro:
Traceback (innermost last):
  Module ZPublisher.Publish, line 138, in publish
  Module ZPublisher.mapply, line 77, in mapply
  Module ZPublisher.Publish, line 48, in call_object
  Module plone.z3cform.layout, line 66, in __call__
  Module plone.z3cform.layout, line 50, in update
  Module plone.dexterity.browser.edit, line 64, in update
  Module plone.z3cform.fieldsets.extensible, line 59, in update
  Module plone.z3cform.patch, line 30, in GroupForm_update
  Module z3c.form.group, line 132, in update
  Module z3c.form.form, line 136, in updateWidgets
  Module z3c.form.field, line 277, in update
  Module z3c.form.browser.multi, line 63, in update
  Module z3c.form.browser.widget, line 171, in update
  Module z3c.form.widget, line 496, in update
  Module z3c.form.widget, line 132, in update
  Module z3c.form.widget, line 491, in value
  Module collective.z3cform.datagridfield.datagridfield, line 147, in updateWidgets
  Module z3c.form.widget, line 433, in updateWidgets
  Module z3c.form.widget, line 410, in applyValue
  Module collective.z3cform.datagridfield.datagridfield, line 257, in set
  Module z3c.form.object, line 208, in updateWidgets
  Module collective.z3cform.datagridfield.autoform, line 60, in update
  Module z3c.form.object, line 87, in update
  Module plone.z3cform.patch, line 21, in BaseForm_update
  Module z3c.form.form, line 154, in update
  Module collective.z3cform.datagridfield.datagridfield, line 315, in updateWidgets
  Module collective.z3cform.datagridfield.autoform, line 40, in updateWidgets
  Module z3c.form.form, line 136, in updateWidgets
  Module z3c.form.field, line 243, in update
  Module z3c.form.datamanager, line 102, in canWrite
  Module z3c.form.datamanager, line 66, in adapted_context
TypeError: ('Could not adapt', 'link-1', <InterfaceClass brasil.gov.paginadestaque.behaviors.metadata.ILinkRow>)

Estamos usando a Versão
Portal Padrão 1.1.5.1
Plone 4.3.9 (4313)
CMF 2.2.9
Zope 2.13.24
Python 2.7.3 (default, Mar 13 2014, 11:03:55) [GCC 4.7.2]
PIL 2.6.1 (Pillow), O sistema operacional em que nosso site está hospedado é Debian 7.9

-- 
Valdir Nascimento dos Santos
Analista de T.I. - DGTI Reitoria
Fone: (71) 2102-0404  -  Cel.: (71)9954-7845


Mais detalhes sobre a lista de discussão PloneGov-BR