[plonegov-br] Ajuda para instalar o Portal Padrão

Nitai B. Silva nitaibezerra em gmail.com
Quinta Outubro 1 15:55:12 BRT 2015


Fico pensando que é chegada a hora dessa solução ter um script docker. Com
certeza vai escalar muito a utilização pelas instituições.

A exemplo https://github.com/servicosgovbr/docker

[] s
Nitai
Em 01/10/2015 12:03, "Davi Lima" <davilima6 em gmail.com> escreveu:

> Outra sugestão é tentar instalar o Plone primeiramente sem o Portal
> Padrão, a fim de eliminar algumas hipóteses. Sugiro tentar a versão 4.3.7,
> mas pode também instalar diretamente a 5.0:
>
>    - https://plone.org/products/plone/releases/4.3.7
>    - https://plone.org/products/plone/releases/5.0
>
> Siga as instruções relativas ao "Unified Installer":
>
>    -
>    http://docs.plone.org/manage/installing/installation.html#installing-plone-using-the-unified-unix-installer
>
> Abs,
> Davi
>
> Em 1 de outubro de 2015 11:54, Davi Lima <davilima6 em gmail.com> escreveu:
>
>> Olá Diogenes.
>>
>> Você não deve informar o IP interno da sua rede, até porque ele pode
>> mudar a cada vez que você reinicia a máquina ou a conexão com a rede. Os
>> IPs e portas são informados no settings.cfg e a princípio não devem ser
>> alterados, ou seja, sua cópia local tem que estar igual a esta:
>> https://github.com/plonegovbr/portal.buildout/blob/master/buildout.d/settings.cfg
>>
>> Seu problema parece ser outro. Por acaso está usando uma máquina virtual
>> e testando no browser do S.O. nativo? Reexecutou o comando ./bin/instance
>> fg novamente antes de testar as URLs que eu passei no último email? O que o
>> browser respondeu, alguma mensagem de erro?
>>
>> Sugiro tentar também em um Linux com ambiente gráfico, ou seja, em uma
>> distribuição mais normal. E informar a distribuição usada também, versões
>> etc.
>>
>> Abs,
>> Davi
>>
>> Em 30 de setembro de 2015 08:14, Diogenes Magalhaes <
>> dmagalhaes em pederneiras.sp.gov.br> escreveu:
>>
>>> Bom dia Davi,
>>>
>>> Muito obrigado pela ajuda.
>>>
>>> Que bom que a instalação está concluída. Mas ainda não consigo acessar.
>>> Como a instalação foi feita em Linux (sem ambiente gráfico) não tive
>>> sucesso pelos endereços mencionados.
>>> Até instalei o links2 para navegação em modo texto, pra ver se abriria,
>>> ao menos, a página inicial; porém nada!
>>>
>>> Creio que ainda falte configurar alguma coisa ou informar, em algum
>>> arquivo.cfg o IP do servidor.
>>> Olhei todos os arquivos em /buildout.d e não achei um local específico
>>> para informar o IP.
>>>
>>> Será que eu não poderia criar uma entrada em base.cfg no bloco
>>>  [instance], como o texto:  Hostname = 192.168.0.20 ?
>>>
>>> Desculpe-me o incômodo com estes assuntos básicos, mas é que, realmente,
>>> não conheço o funcionamento.
>>>
>>> abs.
>>>
>>> Cordialmente
>>>
>>>
>>>
>>> *Diógenes de MagalhãesSecretário Adjunto de *
>>> *Administração*
>>> *Área de Tecnologia da Informação*
>>> *Prefeitura Municipal de Pederneiras*
>>> *(14) 3283-9574 <%2814%29%203283-9574>**(14) 99777-9932
>>> <%2814%29%2099777-9932>*
>>>
>>>
>>> ------------------------------
>>> *De: *"Davi Lima" <davilima6 em gmail.com>
>>> *Para: *"Comunidade Plone no Governo" <
>>> plonegov-br em listas.interlegis.gov.br>
>>> *Enviadas: *Terça-feira, 29 de setembro de 2015 17:18:23
>>> *Assunto: *Re: [plonegov-br]        Ajuda para instalar o Portal Padrão
>>>
>>> Você certamente já conseguiu instalar e subir corretamente a instância,
>>> devido à seguinte mensagem:
>>>
>>>    - 2015-09-29 15:29:24 INFO Zope Ready to handle requests
>>>
>>>  Faltou somente acessá-la no browser em:
>>>
>>>    - http://127.0.0.1:8080/ ou http://0.0.0.0:8080/ ou
>>>    http://localhost:8080/ (todos levam ao mesmo lugar)
>>>
>>> As demais linhas que você destacou são apenas mensagens INFOrmativas.
>>> Poderiam ser WARNINGS, na maioria das vezes ignoráveis, ou então ERRORS,
>>> estes sim impeditivos. Com relação que ele falou do "sauna.reload", é só
>>> uma comodidade para aumentar o ritmo de desenvolvimento vs testes, pode
>>> ignorar por enquanto também.
>>>
>>> abs
>>> Davi
>>>
>>> Em 29 de setembro de 2015 17:03, Diogenes Magalhaes <
>>> dmagalhaes em pederneiras.sp.gov.br> escreveu:
>>>
>>>> Boa tarde Carlos,
>>>>
>>>> Muitíssimo obrigado pela ajuda.
>>>> Removemos a linha do base.cfg e executamos novamente os comandos 2X.
>>>> Dessa forma, seguiu em frente, mas ainda parou na mensagem destacada
>>>> abaixo (abortei com ^C):
>>>>
>>>> (py27)administrador em webportal:~/portal.buildout$ ./bin/instance fg
>>>> 2015-09-29 15:29:10 INFO ZServer HTTP server started at Tue Sep 29
>>>> 15:29:10 2015
>>>> *Hostname: 0.0.0.0*
>>>> * Port: 8080*
>>>> 2015-09-29 15:29:12 INFO Products.PloneFormGen gpg_subprocess
>>>> initialized, using /usr/bin/gpg
>>>> Hold on to your hats folks, I'm a-patchin'
>>>> 2015-09-29 15:29:12 WARNING PrintingMailHost
>>>>
>>>> ******************************************************************************
>>>> Monkey patching MailHosts to print emails to the terminal instead of
>>>> sending them.
>>>> NO MAIL WILL BE SENT FROM ZOPE AT ALL!
>>>> Turn off debug mode or remove PrintingMailHost from the Products
>>>> directory to turn this off.
>>>> .
>>>> .
>>>> .
>>>> 2015-09-29 15:29:23 INFO PloneFormGen Patching plone.app.portlets
>>>> ColumnPortletManagerRenderer to not catch Retry exceptions
>>>> 2015-09-29 15:29:24 INFO Zope Ready to handle requests
>>>> sauna.reload is not installed correctly!
>>>> Your are missing following line from instance part of your buildout:
>>>> zope-conf-additional = %import sauna.reload
>>>> Not starting fork loop.
>>>>
>>>>
>>>> Acho que o Portal ainda não subiu.
>>>>
>>>> http://ip:8080   =  ERR_CONNECTION_REFUSED
>>>>
>>>> Observei que o IP não está informado no campo *Hotname: 0.0.0.0*
>>>> Poderia ser esse o caso do não acesso ?
>>>>
>>>> Agradeço novamente qualquer ajuda.
>>>>
>>>>
>>>> Cordialmente
>>>>
>>>>
>>>> *Diógenes de MagalhãesSecretário Adjunto de *
>>>> *Administração*
>>>> *Área de Tecnologia da Informação*
>>>> *Prefeitura Municipal de Pederneiras*
>>>> *(14) 3283-9574 <%2814%29%203283-9574>**(14) 99777-9932
>>>> <%2814%29%2099777-9932>*
>>>>
>>>>
>>>>
>>>> ------------------------------
>>>> *De: *"Carlos Eduardo Araujo Vieira" <carlos.vieira em planejamento.gov.br
>>>> >
>>>> *Para: *plonegov-br-bounces em listas.interlegis.gov.br, "Comunidade
>>>> Plone no Governo" <plonegov-br em listas.interlegis.gov.br>
>>>> *Enviadas: *Terça-feira, 29 de setembro de 2015 11:20:56
>>>> *Assunto: *Re: [plonegov-br]        Ajuda para instalar o Portal Padrão
>>>>
>>>> Dentro do arquivo buildout.d/base.cfg remova a linha:
>>>>
>>>>
>>>> "extensions = buildout-versions"
>>>>
>>>>
>>>> Execute novamente o
>>>>         python bootstrap.py -c buildout.cfg
>>>>         ./bin/buildout -c buildout.cfg
>>>>
>>>> Vai dar conflito com o setutools. Execute o ./bin/buildout -c
>>>> buildout.cfg uma segunda vez.
>>>>
>>>> Isso é uma gambiarra para você executar em modo desenvolvimento. Para
>>>> produção melhor abrir uma issue pois não sei o que o conflito de versões do
>>>> setuptools vai trazer se esse erro se mantiver.
>>>>
>>>> Carlos Vieira
>>>>
>>>>
>>>> ------------------------------
>>>> *De:* plonegov-br-bounces em listas.interlegis.gov.br <
>>>> plonegov-br-bounces em listas.interlegis.gov.br> em nome de Diogenes
>>>> Magalhaes <dmagalhaes em pederneiras.sp.gov.br>
>>>> *Enviado:* segunda-feira, 28 de setembro de 2015 17:02
>>>> *Para:* plonegov-br-bounces em listas.interlegis.gov.br
>>>> *Cc:* Comunidade Plone no Governo
>>>> *Assunto:* [plonegov-br] Ajuda para instalar o Portal Padrão
>>>>
>>>>
>>>> Boa tarde Srs,
>>>>
>>>> Gostaria de saber se alguém poderia nos ajudar na instalação do Portal
>>>> Padrão, em plone.
>>>>
>>>> Pensando que fosse algo simples seguimos as orientações do link:
>>>> http://identidade-digital-de-governo-plone.readthedocs.org/en/latest/
>>>> como roteiro (receita de bolo), mas tivemos alguns problemas.
>>>>
>>>> As fase concluídas foram:
>>>>
>>>> * Configurações Básicas [todos os passos OK]
>>>>         Pré-Requisitos
>>>>               Sistema Operacional: Ubuntu 14.04 LTS  em máquina virtual
>>>> no vmware 5.5
>>>>               Memória Mínima: 2GB
>>>>         Preparação do ambiente
>>>>               Acesso internet
>>>>               Configurando proxy
>>>>               Pacotes do sistema
>>>> * Ambiente de desenvolvimento
>>>>         Instalando o código do Portal
>>>>               Usando repositório
>>>>                      Clone deste buildout (com https): git clone
>>>> https://github.com/plonegovbr/portal.buildout.git portal.buildout
>>>>                      Criar um virtualenv apartado do restante do
>>>> sistema:
>>>>                                admin-não-root$  cd ~/portal.buildout
>>>>                                admin-não-root$  virtualenv py27
>>>>                                admin-não-root$  source
>>>> py27/bin/activate
>>>>                      *Criar um novo arquivo* de configuração*
>>>> buildout.cfg*, que estende o development.cfg para definir variáveis
>>>> deste ambiente:
>>>>                                [buildout]
>>>>                                extends =
>>>>                                        development.cfg
>>>>
>>>>                                [remotes]
>>>>                                plonegovbr =
>>>> https://github.com/plonegovbr
>>>>                                collective =
>>>> https://github.com/collective
>>>>                                plone = https://github.com/plone
>>>>                                simplesconsultoria =
>>>> https://github.com/simplesconsultoria
>>>>
>>>> *Até aqui OK.*
>>>>
>>>> Tivemos problemas ao executar o buildout com as configurações para
>>>> ambiente de produção – buildout.cfg:
>>>>                                python bootstrap.py -c buildout.cfg
>>>>    ===>>> este passo OK
>>>>                                ./bin/buildout -c buildout.cfg
>>>>        ===>>> aqui temos problema.
>>>>
>>>> Resposta:
>>>>
>>>> (py27)administrador em webportal:~/portal.buildout$ ./bin/buildout -c
>>>> buildout.cfg
>>>> While:
>>>> Installing.
>>>> Loading extensions.
>>>> Error: Buildout now includes 'buildout-versions' (and part of the older
>>>> 'buildout.dumppickedversions').
>>>> Remove the extension from your configuration and look at the
>>>> 'show-picked-versions' option in buildout's documentation.
>>>> (py27)administrador em webportal:~/portal.buildout$
>>>>
>>>>
>>>> Alguém poderia orientar o que está errado ?
>>>>
>>>> *Não continuamos* a sequência nos próximos comandos de *Inicialização
>>>> e Controle*.
>>>>
>>>> Desculpe-nos se algo não ficou claro; não temos conhecimento em Plone.
>>>>
>>>> Obrigado.
>>>>
>>>> Cordialmente
>>>>
>>>>
>>>> *Diógenes de Magalhães Secretário Adjunto de *
>>>> *Administração *
>>>> *Área de Tecnologia da Informação *
>>>> *Prefeitura Municipal de Pederneiras *
>>>> *(14) 3283-9574 <%2814%29%203283-9574> **(14) 99777-9932
>>>> <%2814%29%2099777-9932>*
>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> Comunidade Plone no Governo
>>>> Site: http://www.softwarelivre.gov.br/plone
>>>> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
>>>> Histórico:
>>>> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>>>> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>>>>
>>>> --
>>>> Comunidade Plone no Governo
>>>> Site: http://www.softwarelivre.gov.br/plone
>>>> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
>>>> Histórico:
>>>> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>>>> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>>>>
>>>
>>>
>>> --
>>> Comunidade Plone no Governo
>>> Site: http://www.softwarelivre.gov.br/plone
>>> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
>>> Histórico:
>>> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>>> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>>>
>>> --
>>> Comunidade Plone no Governo
>>> Site: http://www.softwarelivre.gov.br/plone
>>> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
>>> Histórico:
>>> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>>> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>>>
>>
>>
>
> --
> Comunidade Plone no Governo
> Site: http://www.softwarelivre.gov.br/plone
> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
> Histórico:
> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/plonegov-br/attachments/20151001/676e61a1/attachment.html>


Mais detalhes sobre a lista de discussão PloneGov-BR