[plonegov-br] Instalação de Plone em Ubuntu

Júlio César Medina Madruga julio.cesar em furg.br
Quarta Junho 10 14:43:55 BRT 2015



Senhores, agradeço pela atenção. Testei com liberação completa para o ip
da máquina e funcionou (se alguém puder me dizer que serviços e/ou
endereços sinistros são solicitados para que possamos detectar o que
ocasionou algum bloqueio, eu agradeço. 

O problema agora está na
inicialização do serviço, executei o supervisor e chequei o status... vejam
só o que retornou para mim: 

(py27)plone em void:/opt/portal.buildout$
./bin/supervisorctl status
haproxy FATAL Exited too quickly (process log
may have details)
instance1 FATAL Exited too quickly (process log may have
details)
instance2 FATAL Exited too quickly (process log may have
details)
zeo RUNNING pid 9877, uptime 0:12:39 

Isso rodando como usuário
plone, e no log stdout do instance2 me diz algo tipo 

Traceback (most
recent call last):
 File
"/opt/portal.buildout/parts/instance2/bin/interpreter", line 348, in 

execfile(__file__)
 File
"/opt/portal.buildout/eggs/Zope2-2.13.22-py2.7.egg/Zope2/Startup/run.py",
line 76, in 
 run()
 File
"/opt/portal.buildout/eggs/Zope2-2.13.22-py2.7.egg/Zope2/Startup/run.py",
line 22, in run
 starter.prepare()
 File
"/opt/portal.buildout/eggs/Zope2-2.13.22-py2.7.egg/Zope2/Startup/__init__.py",
line 79, in prepare
 self.setupServers()
 File
"/opt/portal.buildout/eggs/Zope2-2.13.22-py2.7.egg/Zope2/Startup/__init__.py",
line 214, in setupServers
 %
(server.servertype(),e[1]))
ZConfig.ConfigurationError: There was a problem
starting a server of type "HTTPServer". This may mean that your user does
not have permission to bind to the port which the server is trying to use
or the port may already be in use by another application. (Cannot assign
requested address) 

A seguir testei voltar como root e reinicializar o
supervisor, daí o haproxy já rodou, porém os demais instances fail de novo


root em void:/opt/portal.buildout# ./bin/supervisorctl status
haproxy
RUNNING pid 9956, uptime 0:01:15
instance1 FATAL Exited too quickly
(process log may have details)
instance2 FATAL Exited too quickly (process
log may have details)
zeo RUNNING pid 9955, uptime 0:01:15 

e o erro acima
foi o que se repetiu no log. 

Alguém tem uma luz ??? 

On Wed, 10 Jun 2015
13:33:08 -0300, Ricardo Pereira  wrote:     Arquivo corrompido = Perda de
pacotes no caminho. Talvez 
HD com trilhas defeituosas. Talvez.

 Eu
tentaria instalar noutra maquina, ate mesmo noutra maquina e noutra rede,
só para ter a certeza de que o problema esta na origem e não no destino.


Ja tive problemas parecidos, com arquivos supostamente corrompidos, vindo
de Download de internet ( apt-get ), mas no fim, descobri que era HD
defeituoso. 
 Em 9 de junho de 2015 19:34, Jomar Xavier  escreveu:
   Deve
ter proxy no meio da parada.

Enviado do meu iPhone   
Em 09/06/2015, às
18:21, Júlio César Medina Madruga  escreveu:

Não tentei de outra máquina,
mas na mesma já zerei a instalação, criei a pasta novamente e fiz o
processo até travar no mesmo procedimento!
Outra coisa, no início tive que
direcionar a clonagem do Git pelo https, por ssh não teve santo que
ajudasse...  

On Tue, 9 Jun 2015 15:46:46 -0300, Davi Lima  wrote:  Boa
tarde, Você pode rodar o buildout com um número repetido da opção "v" para
aumentar o nível de detalhe do log de saída, ex: ./bin/buildout -vvvvvv Com
isso você deve obter mais informações sobre qual exatamente é o erro ao
instalar o pacote. Além disso há um arquivo oculto ".installed.cfg" no
diretório home do buildout que pode ser consultado para entender o erro.
Vale a pena reiniciar o processo do zero a partir de um novo diretório para
evitar caches quebrados ou downloads corruptos, já tentou isso? Já tentou
de outra máquina e/ou de outra rede? Até onde eu saiba, o PyPI só
disponibiliza downloads https. []s Davi 

 2015-06-09 15:02 GMT-03:00
Bernardo Silva :
  Pessoal, notar o erro, acredito que ele estava
resolvendo dependências e quando resolveu ir ao repositório baixar teve
problemas Getting required 'Products.ResourceRegistries==2.2.10'
We have
the distribution that satisfies 'Products.ResourceRegistries==2.2.10'.


Getting required 'Products.PortalTransforms==2.1.3'
We have no
distributions for Products.PortalTransforms that satisfies
'Products.PortalTransforms==2.1.3'.

 Getting distribution for
'Products.PortalTransforms==2.1.3'.

While:
 Installing instance.
 Getting
distribution for 'Products.PortalTransforms==2.1.3'.

An internal error
occurred due to a bug in either zc.buildout or in a
 Alguém sabe confirmar
qual é o protocolo utilizado para buscar as coisas no pypi, http, https,
ssh, git? se calguem conseguir confirmar a url do repositorio
"Products.PortalTransforms"    
   Bernardo Silva Analista de Tecnologia da
Informação Universidade Federal do Rio Grande - FURG           

-- 
Júlio
César Madruga

Acadêmico de Bacharelado de Sistemas de Informação 

C3 -
FURG

Técnico de Tecnologia de Informação

NTI - FURG
       -- 
Comunidade
Plone no Governo
Site: http://www.softwarelivre.gov.br/plone [5]
Wiki:
http://colab.interlegis.leg.br/wiki/PloneGovBr [6]
Histórico:
http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
[7]
Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
[8]   
--
 Comunidade Plone no Governo
 Site:
http://www.softwarelivre.gov.br/plone [9]
 Wiki:
http://colab.interlegis.leg.br/wiki/PloneGovBr [10]
 Histórico:
http://colab.interlegis.leg.br/search/?type=thread&order=latest">RICARDO
PEREIRA DE AZEVEDO - Técnico Administrativo_    

-- 
Júlio César
Madruga

Acadêmico de Bacharelado de Sistemas de Informação 

C3 -
FURG

Técnico de Tecnologia de Informação

NTI - FURG
  wget
https://pypi.python.org/packages/source/b/brasil.gov.portal/brasil.gov.portal-1.0.5.zip
[13] (py27)plone em void:/opt/portal.buildout$ ./bin/supervisorctl
status
haproxy FATAL Exited too quickly (process log may have
details)
instance1 FATAL Exited too quickly (process log may have
details)
instance2 FATAL Exited too quickly (process log may have
details)
zeo RUNNING pid 9877, uptime 0:12:39



Links:
------
[1]
mailto:jomar.xavier em gmail.com
[2] mailto:julio.cesar em furg.br
[3]
mailto:davilima6 em gmail.com
[4] mailto:bernardo.silva em furg.br
[5]
http://www.softwarelivre.gov.br/plone
[6]
http://colab.interlegis.leg.br/wiki/PloneGovBr
[7]
http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
[8]
https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
[9]
http://www.softwarelivre.gov.br/plone
[10]
http://colab.interlegis.leg.br/wiki/PloneGovBr
[11]
http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
[12]
https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
[13]
https://pypi.python.org/packages/source/b/brasil.gov.portal/brasil.gov.portal-1.0.5.zip
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/plonegov-br/attachments/20150610/19476c67/attachment.html>


Mais detalhes sobre a lista de discussão PloneGov-BR