[plonegov-br] Dúvida na instalação do Portal Padrão com configuração de Produção

Carlitos Fioravante V. de Oliveira carlitos.oliveira em ifms.edu.br
Quinta Julho 30 09:12:15 BRT 2015


Pessoal, alguma ideia de como fazer o haproxy rodar com o usuário plone? Já
tentei várias coisas aqui e nada até agora =/


Ats,


*Carlitos Fioravante V. de Oliveira*
Coordenador de Sistemas (COSIS)
Diretoria de Gestão de Tecnologia da Informação - DIRTI
Instituto Federal de Educação, Ciência e
Tecnologia de Mato Grosso do Sul
R. Ceará, 972 - Santa Fé
Campo Grande - MS
(67) 3378-9568
*carlitos.oliveira em ifms.edu.br <carlitos.oliveira em ifms.edu.br>*
_______

*"Tudo quanto te vier à mão para fazer, faze-o conforme as tuas forças
..." (**Ec. 9:10**)*


Em 23 de julho de 2015 11:25, Carlitos Fioravante V. de Oliveira <
carlitos.oliveira em ifms.edu.br> escreveu:

> Ah, esqueci de falar... monitorei os logs como você pediu Héctor, porém
> não vem nenhuma informação importante, veja:
>
> No /opt/portal-buildout/var/log/supervisor.log só mostra assim:
>
> 2015-07-23 09:28:56,298 INFO exited: haproxy (exit status 1; not expected)
> 2015-07-23 09:28:57,300 INFO spawned: 'haproxy' with pid 1860
> 2015-07-23 09:28:57,305 INFO exited: haproxy (exit status 1; not expected)
> 2015-07-23 09:28:59,309 INFO spawned: 'haproxy' with pid 1875
> 2015-07-23 09:28:59,314 INFO exited: haproxy (exit status 1; not expected)
> 2015-07-23 09:29:02,319 INFO spawned: 'haproxy' with pid 1876
> 2015-07-23 09:29:02,323 INFO exited: haproxy (exit status 1; not expected)
> 2015-07-23 09:29:03,325 INFO gave up: haproxy entered FATAL state, too
> many start retries too quickly
>
> Parece que ele tenta umas 4 vezes levantar o haproxy, até desistir
>
> Tem mais outros 2 logs do haproxy: um é o stdout e outro o stderr, mas não
> traz nada...
>
>
> Ats,
>
>
> *Carlitos Fioravante V. de Oliveira*
> Coordenador de Sistemas (COSIS)
> Diretoria de Gestão de Tecnologia da Informação - DIRTI
> Instituto Federal de Educação, Ciência e
> Tecnologia de Mato Grosso do Sul
> R. Ceará, 972 - Santa Fé
> Campo Grande - MS
> (67) 3378-9568
> *carlitos.oliveira em ifms.edu.br <carlitos.oliveira em ifms.edu.br>*
> _______
>
> *"Tudo quanto te vier à mão para fazer, faze-o conforme as tuas forças ..." (**Ec. 9:10**)*
>
>
> Em 23 de julho de 2015 11:19, Carlitos Fioravante V. de Oliveira <
> carlitos.oliveira em ifms.edu.br> escreveu:
>
>> *Ricardo Brito*, bom dia!
>>
>> Valeu pelas orientações, mas já havia visto esse site e ele acabou me
>> confundindo mais =). Eu tentei realizar a instalação do portal padrão em
>> uns 3 debians diferentes e ocorrerram os mesmos problemas ou piores,
>> portanto voltei para o Ubuntu que é praticamente um filho do Debian, né?
>> Estou usando agora do Ubuntu 14.04 e foi o que melhor desenrolou até agora.
>>
>>
>> *Héctor Velarde*, bom dia!
>>
>> Nem sei como agradecer suas explicações, ontem já havia lido outra
>> resposta sua no grupo e já tinha clareado bastante coisa pra mim, agora
>> então acho que já tá quase 100%. Bom, mas tem alguns probleminhas ainda,
>> vamos lá:
>>
>> 1) Não precisei mais usar o easy_install, ele baixou tudo
>> automagicamente, acredito que foi por conta de algum problema de conexão no
>> momento;
>>
>> 2) Realmente as instancias 1 e 2 levantam respectivamente nas portas:
>> 8081 e 8082, mas no meu caso tive que entrar no arquivo de configuração do
>> haproxy, haproxy.conf e mudar os endereços das instancias de 127.0.0.1 para
>> o IP de saída minha máquina (no meu caso: 192.168.56.11). Eu só
>> identifiquei isso quando fui lá no192.168.56.11:8000/haproxy-status e vi
>> que as duas instances estavam DOWN. Então após fazer a alteração do IP no
>> haproxy.conf ficou tudo UP;
>>
>> 3) Eu tento executar o supervisor com o plone, porém o haproxy não
>> levanta. Aproveitei e alterei aquele usuário "portal" que você mencionou lá
>> do settings.cfg (
>> https://github.com/plonegovbr/portal.buildout/blob/master/buildout.d/settings.cfg#L15)
>> mesmo já tendo o usuário os = plone no buildout.cfg, rodei tudo denovo e
>> permaneceu na mesma.
>>
>> 4) No usuário root foi tudo lindo. Haproxy, zeo e as duas instancias
>> RUNNING. Acesso normalmente o portal pela porta 8000 de entrada do haproxy.
>>
>> Aproveitando, já gostaria de saber de vocês o que vcs tem utilizado para
>> fazer esse redirecionamento do 8000 para a 80 (por exemplo), bem como
>> fechar as demais portas (8000, 8081, 8082, 7000...) para o acesso externo?
>>
>> Agradeço a compreensão,
>>
>>
>> Ats,
>>
>>
>> *Carlitos Fioravante V. de Oliveira*
>> Coordenador de Sistemas (COSIS)
>> Diretoria de Gestão de Tecnologia da Informação - DIRTI
>> Instituto Federal de Educação, Ciência e
>> Tecnologia de Mato Grosso do Sul
>> R. Ceará, 972 - Santa Fé
>> Campo Grande - MS
>> (67) 3378-9568
>> *carlitos.oliveira em ifms.edu.br <carlitos.oliveira em ifms.edu.br>*
>> _______
>>
>> *"Tudo quanto te vier à mão para fazer, faze-o conforme as tuas forças ..." (**Ec. 9:10**)*
>>
>>
>> 2015-07-23 11:15 GMT-04:00 Héctor Velarde <
>> hector em simplesconsultoria.com.br>:
>>
>>> show, André! por favor crie um branch, adicione as colaborações e faça
>>> um pull request para revisão.
>>>
>>> muito obrigado
>>>
>>> Héctor Velarde
>>> Simples Consultoria
>>>
>>>
>>> --
>>> Comunidade Plone no Governo
>>> Site: http://www.softwarelivre.gov.br/plone
>>> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
>>> Histórico:
>>> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>>> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>>>
>>
>>
>
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/plonegov-br/attachments/20150730/b4bf2649/attachment.html>


Mais detalhes sobre a lista de discussão PloneGov-BR