[plonegov-br] haproxy não levanta o serviço.

Rodrigo Ferreira de Souza rodfersou em gmail.com
Quarta Agosto 26 11:40:29 BRT 2015


Olá,

Vi uma discussào sobre o problema de configuração no github, e foi
levantada se existe a real necessidade do uso do Haproxy, já que tanto o
Nginx quanto o Varnish podem fazer o mesmo serviço de balanceamento de
cargas.

Tomei a liberdade de abrir uma nova issue
<https://github.com/plonegovbr/portal.buildout/issues/25> sobre o assunto,
e gostaria da ajuda da opnião e experiência de todos sobre o assunto.

Abraços,
Rodrigo

Atenciosamente,
Rodrigo Ferreira de Souza

python -c "n='H+6(13+zT5((51(9z65zG+%
9';s=len(n)-1;i=list(range(s+1))[::-1]+list(range(1,s+1));print('\n'.join(['
'.join([chr(154-ord(n[(x if x > y else y)])) for y in i]) for x in i]))"


2015-08-20 14:44 GMT-03:00 Luiz Hamilton Roberto da Silva <
luiz.silva em ifap.edu.br>:

> Caro André Domarques,
>
> Esse foi o "pulo do gato", fiz aqui... rebootei a máquina e voltou com os
> serviços up.....
>
> valeu... um grande abraço....
>
>
>
>
> *--*
> *Luiz Hamilton Roberto da Silva*
> *Analista de Tecnologia da Informação *
> *Instituto Federal de Educação, Ciência e Tecnologia do Amapá - IFAP*
>
>
> Em 20 de agosto de 2015 11:49, André Domarques <domarques em gmail.com>
> escreveu:
>
>> Bom dia!
>>
>> Eu já consegui resolver o problema e já me prontifiquei a auxiliar na
>> correção, entretanto, ultimamente estou sem muito tempo para enviar o pull
>> request que não só envolve isso mas outras pequenas melhorias.
>>
>> Veja se isso resolve por enquanto:
>>
>> Se em seu *production.cfg* estiver semelhante a:
>>
>> [supervisor]
>> ...
>> 20 haproxy  (autostart=true  startsecs=35)
>>  ${buildout:directory}/bin/haproxy [ -f
>> ${buildout:directory}/etc/haproxy.conf -db ]*${users:os}*
>> ...
>>
>>
>> Comente as diretivas user/group na seção global em *etc/haproxy.conf*:
>>
>> global
>>   ...
>>   *#user     plone*
>> *  #group    plone*
>>   ...
>>
>>
>> E tente reiniciar os serviços:
>> ./bin/supervisorctl stop all && ./bin/supervisorctl start all
>>
>>
>> Att,
>>
>> Adm. André Domarques
>> Consultor em Tecnologia da Informação e Comunicação
>> 82 9921-6184 | domarques.com.br
>>
>> 2015-08-20 11:01 GMT-03:00 Carlitos Fioravante V. de Oliveira <
>> carlitos.oliveira em ifms.edu.br>:
>>
>>> *Também estou com esse mesmo problema*. Já falei com o pessoal da Secom
>>> e até me repassaram para um técnico de uma outra empresa, porém até o
>>> momento NENHUMA RESPOSTA.
>>>
>>> Ats,
>>>
>>> *Carlitos Fioravante V. de Oliveira*
>>> Coordenador de Sistemas (COSIS)
>>> Diretoria de Gestão de Tecnologia da Informação - DIRTI
>>> Instituto Federal de Educação, Ciência e
>>> Tecnologia de Mato Grosso do Sul
>>>
>>>
>>> Em 20 de agosto de 2015 09:18, Gleisson Henrique <gleissonbr em gmail.com>
>>> escreveu:
>>>
>>>> tenho esse problema desde sempre :( nunca consegui resolver. Caso
>>>> alguém tenha uma solução seria ótimo.
>>>>
>>>> Abraço,
>>>> Gleisson Henrique
>>>>
>>>> 2015-08-20 7:07 GMT-04:00 Luiz Hamilton Roberto da Silva <
>>>> luiz.silva em ifap.edu.br>:
>>>>
>>>>> Caros,
>>>>>
>>>>> Quem já passou pelo mesmo problema e já conseguiu resolver, por favor,
>>>>> o meu serviço haproxy não levanta e, consequentemente não é possível
>>>>> enxergar o portal pelo endereço do domínio, a não ser que se digite as
>>>>> portas 9081 e 9082.
>>>>>
>>>>> haproxy                          FATAL      Exited too quickly
>>>>> (process log may have details)
>>>>> instance1                        RUNNING    pid 8213, uptime 16:33:38
>>>>> instance2                        RUNNING    pid 8236, uptime 16:33:16
>>>>> zeo                              RUNNING    pid 8210, uptime 16:33:38
>>>>>
>>>>>
>>>>> Alguém com a solução? Por favor me ajudem....
>>>>>
>>>>> Abraços,
>>>>>
>>>>>
>>>>> *--*
>>>>> *Luiz Hamilton Roberto da Silva*
>>>>> *Analista de Tecnologia da Informação *
>>>>> *Instituto Federal de Educação, Ciência e Tecnologia do Amapá - IFAP*
>>>>>
>>>>>
>>>>> --
>>>>> Comunidade Plone no Governo
>>>>> Site: http://www.softwarelivre.gov.br/plone
>>>>> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
>>>>> Histórico:
>>>>> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>>>>> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>>>>>
>>>>
>>>>
>>>> --
>>>> Comunidade Plone no Governo
>>>> Site: http://www.softwarelivre.gov.br/plone
>>>> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
>>>> Histórico:
>>>> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>>>> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>>>>
>>>
>>>
>>> --
>>> Comunidade Plone no Governo
>>> Site: http://www.softwarelivre.gov.br/plone
>>> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
>>> Histórico:
>>> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>>> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>>>
>>
>>
>> --
>> Comunidade Plone no Governo
>> Site: http://www.softwarelivre.gov.br/plone
>> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
>> Histórico:
>> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>>
>
>
> --
> Comunidade Plone no Governo
> Site: http://www.softwarelivre.gov.br/plone
> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
> Histórico:
> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/plonegov-br/attachments/20150826/f27fbe68/attachment.html>


Mais detalhes sobre a lista de discussão PloneGov-BR