[plonegov-br] Troca de porta

Samuel Barbosa Costa da Silva samuelbarbosa em ifto.edu.br
Segunda Abril 6 16:05:15 BRT 2015


Entendi. Fiz o proxy reverse pelo apache que já tinha instalado.

Obrigado.


*Samuel Barbosa*

Coordenador De Gestão De Tecnologia Da Informação
Instituto Federal De Educação, Ciência E Tecnologia Do Tocantins
Campus Paraíso Do Tocantins

------------------------------

Fone: +55 63 3361-0314     Fone: +55 63 9984-6780Email:
samuelbarbosa em ifto.edu.brSuporte: http://paraiso.ifto.edu.br/suporte
<https://www.facebook.com/Smk.Barbosa>
<http://twitter.com/smk_barbosa>
<https://plus.google.com/u/0/+SamuelBarbosa_1/posts>smk.barbosa


Em 6 de abril de 2015 15:39, Carlos Eduardo <
carlos.vieira em planejamento.gov.br> escreveu:

>  Boa tarde,
>
> Portas abaixo de 1024 são privilegiadas e só podem ser utilizadas com
> permissões de root. Claro que tem formas de contornar isso mas creio que
> você não esteja utilizando isso. [1]
>
> Faça duas checks:
> 1 - Não existe nenhum outro processo rodando na porta 80 (Um servidor
> apache por exemplo);
> 2 - Esteja subindo a instância com privilégios para a porta 80. (Todos os
> sites que vi indicam não fazer isso e utilizar um proxy reverso [2])
>
> A boa prática é seguir o que o sdupton fala:
>
> "For port 80, you need to run as root; don't do that. You should not run
> Plone on port 80 anyway. Pick a reverse proxy server like Apache httpd,
> nginx, or varnish on port 80/443, and use that in front of Plone on a TCP
> port >1024. All this is very well documented in the standard places" [2]
>
> Atenciosamente,
> Carlos Vieira
>
> [1]
> http://stackoverflow.com/questions/10182798/why-are-ports-below-1024-privileged
> [2] http://stackoverflow.com/questions/27153867/plone-on-ubuntu-port-80
>
>
> On 06/04/2015 15:17, Samuel Barbosa Costa da Silva wrote:
>
>  Boa tarde,
>
>  estou tentando subir um site no plone, alterei a porta para a 80, rodei
> o buildout novamente. O ZeoServer e o Haproxy iniciam, porém as instâncias
> não. No log da instância, recebo a mensagem:
>
>  ZConfig.ConfigurationError: There was a problem starting a server of
> type "HTTPServer". This may mean that your user does not have permission to
> bind to the port which the server is trying to use or the port may already
> be in use by another application. (Permission denied)
>
>
>  Poderiam me explicar o que fazer?
>
>  Grato,
>
> *Samuel Barbosa*
>
> Coordenador De Gestão De Tecnologia Da Informação
> Instituto Federal De Educação, Ciência E Tecnologia Do Tocantins
> Campus Paraíso Do Tocantins
>
> ------------------------------
>
> Fone: +55 63 3361-0314     Fone: +55 63 9984-6780Email: samuelbarbosa em ifto.edu.brSuporte: http://paraiso.ifto.edu.br/suporte  <https://www.facebook.com/Smk.Barbosa> <http://twitter.com/smk_barbosa> <https://plus.google.com/u/0/+SamuelBarbosa_1/posts>smk.barbosa
>
>
>
>
>
> --
> Comunidade Plone no Governo
> Site: http://www.softwarelivre.gov.br/plone
> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
> Histórico:
> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/plonegov-br/attachments/20150406/19180882/attachment.html>


Mais detalhes sobre a lista de discussão PloneGov-BR