[plonegov-br] Tema Brasil.gov

Robério mrcferro em gmail.com
Quarta Outubro 1 15:13:17 BRT 2014


também não

Em 1 de outubro de 2014 15:07, Bruno Barbosa <bsbruno1 em gmail.com> escreveu:

> Conseguiu subir a instância em foreground? ./bin/client1 fg
>
> --
> Bruno Barbosa
> http://brunobarbosa.com.br/
> bsbruno1 em gmail.com
>
> 2014-10-01 13:42 GMT-03:00 Robério <mrcferro em gmail.com>:
>
> Oi Bruno,
>>
>> Quando executo "plonectl stop" a mesma mensagem aparece:
>>
>>
>> root em plone-01:/var/www/plone/zeocluster# ./bin/plonectl stop
>> client1: Traceback (most recent call last):
>>   File "./bin/plonectl", line 15, in <module>
>>     sys.exit(plone.recipe.unifiedinstaller.ctl.main(server='zeoserver',
>> clients=['client1', 'client2'], location=r'/var/www/plone/zeocluster',
>> binDirectory=r'/var/www/plone/zeocluster/bin',
>> fileStorage=r'/var/www/plone/zeocluster/var/filestorage/Data.fs'))
>>   File
>> "/var/www/plone/buildout-cache/eggs/plone.recipe.unifiedinstaller-4.1-py2.6.egg/plone/recipe/unifiedinstaller/ctl.py",
>> line 120, in main
>>     returncode = controller.runCommand(component, command)
>>   File
>> "/var/www/plone/buildout-cache/eggs/plone.recipe.unifiedinstaller-4.1-py2.6.egg/plone/recipe/unifiedinstaller/ctl.py",
>> line 83, in runCommand
>>     po = subprocess.Popen(args)
>>   File "/var/www/plone/Python-2.6/lib/python2.6/subprocess.py", line 623,
>> in __init__
>>     errread, errwrite)
>>   File "/var/www/plone/Python-2.6/lib/python2.6/subprocess.py", line
>> 1141, in _execute_child
>>     raise child_exception
>> OSError: [Errno 2] No such file or directory
>>
>>
>>
>> Já os comandos "./bin/buildout -Nv" e "./bin/zeoserver start"
>> funcionaram normalmente.
>>
>> Em 30 de setembro de 2014 14:07, Bruno Barbosa <bsbruno1 em gmail.com>
>> escreveu:
>>
>> Robério,
>>>
>>> Vamos refazer os passos para identificar onde está o problema:
>>>
>>>    1. Acesse o diretório zeocluster, todos os comandos à seguir vamos
>>>    executá-los a partir deste diretório;
>>>    2. Pare o zeoserver e todas as instâncias: ./bin/plonectl stop
>>>    3. Rode o buildout: ./bin/buildout -Nv
>>>    4. Inicie o zeoserver: ./bin/zeoserver start
>>>    5. Inicie a primeira instância em foreground (fg): ./bin/client1 fg
>>>
>>> Veja se gera alguma exceção e posta aqui na lista.
>>>
>>> Abs.
>>>
>>> --
>>> Bruno Barbosa
>>> http://brunobarbosa.com.br/
>>> bsbruno1 em gmail.com
>>>
>>> Em 30 de setembro de 2014 12:43, Robério <mrcferro em gmail.com> escreveu:
>>>
>>>> Bom dia!
>>>>
>>>> Tentei instalar o tema brasil.gov, mas não obtive êxito na instalação.
>>>> Segui os seguintes passos:
>>>>
>>>>
>>>>    1. Inseri a seguinte linha em eggs, no arquivo buildout.cfg (segui
>>>>    a orientação descrita em
>>>>    https://pypi.python.org/pypi/brasil.gov.portal/1.0.3):
>>>>    brasil.gov.portal
>>>>    2. Salvei o arquivo, e executei o comando:
>>>>    bin/buildout
>>>>    3. Parei o Plone
>>>>    bin/plonectl stop
>>>>
>>>> O resultado (antes de tentar iniciar o plone) foi essa mensagem:
>>>>
>>>> client1: Traceback (most recent call last):
>>>>   File "bin/plonectl", line 15, in <module>
>>>>     sys.exit(plone.recipe.unifiedinstaller.ctl.main(server='zeoserver',
>>>> clients=['client1', 'client2'], location=r'/var/www/plone/zeocluster',
>>>> binDirectory=r'/var/www/plone/zeocluster/bin',
>>>> fileStorage=r'/var/www/plone/zeocluster/var/filestorage/Data.fs'))
>>>>   File
>>>> "/var/www/plone/buildout-cache/eggs/plone.recipe.unifiedinstaller-4.1-py2.6.egg/plone/recipe/unifiedinstaller/ctl.py",
>>>> line 120, in main
>>>>     returncode = controller.runCommand(component, command)
>>>>   File
>>>> "/var/www/plone/buildout-cache/eggs/plone.recipe.unifiedinstaller-4.1-py2.6.egg/plone/recipe/unifiedinstaller/ctl.py",
>>>> line 83, in runCommand
>>>>     po = subprocess.Popen(args)
>>>>   File "/var/www/plone/Python-2.6/lib/python2.6/subprocess.py", line
>>>> 623, in __init__
>>>>     errread, errwrite)
>>>>   File "/var/www/plone/Python-2.6/lib/python2.6/subprocess.py", line
>>>> 1141, in _execute_child
>>>>     raise child_exception
>>>> OSError: [Errno 2] No such file or directory
>>>>
>>>>
>>>> Estou usando a versão 4.3.3... alguém de ideia sobre como resolver esse
>>>> problema?
>>>>
>>>>
>>>> --
>>>> Robério
>>>>
>>>>
>>>> --
>>>> Comunidade Plone no Governo
>>>> Site: http://www.softwarelivre.gov.br/plone
>>>> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
>>>> Histórico:
>>>> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>>>> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>>>>
>>>
>>>
>>> --
>>> Comunidade Plone no Governo
>>> Site: http://www.softwarelivre.gov.br/plone
>>> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
>>> Histórico:
>>> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>>> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>>>
>>
>>
>>
>> --
>> Robério
>>
>>
>> --
>> Comunidade Plone no Governo
>> Site: http://www.softwarelivre.gov.br/plone
>> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
>> Histórico:
>> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
>> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>>
>
>
> --
> Comunidade Plone no Governo
> Site: http://www.softwarelivre.gov.br/plone
> Wiki: http://colab.interlegis.leg.br/wiki/PloneGovBr
> Histórico:
> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=plonegov-br
> Lista: https://listas.interlegis.gov.br/mailman/listinfo/plonegov-br
>



-- 
Robério
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/plonegov-br/attachments/20141001/87593a84/attachment.html>


Mais detalhes sobre a lista de discussão PloneGov-BR