<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    <p>Pois é , mas aqui, mesmo observando  todos detalhes, os erros de
      instalação são referentes ao repositórios do Ubuntu, vejam;</p>
    <p> <i>curl -ssl <a class="moz-txt-link-freetext" href="https://get.docker.com">https://get.docker.com</a> | sh</i><i><br>
      </i><i># Executing docker install script, commit: 716f7ca</i><i><br>
      </i><i>+ sh -c apt-get update -qq >/dev/null</i><i><br>
      </i><i>W: The repository
        '<a class="moz-txt-link-freetext" href="http://ppa.launchpad.net/fta/gnome3/ubuntu">http://ppa.launchpad.net/fta/gnome3/ubuntu</a> xenial Release' does
        not have a Release file.</i><i><br>
      </i><i>E: Falhou ao buscar
<a class="moz-txt-link-freetext" href="http://ppa.launchpad.net/fta/gnome3/ubuntu/dists/xenial/main/binary-amd64/Packages">http://ppa.launchpad.net/fta/gnome3/ubuntu/dists/xenial/main/binary-amd64/Packages</a> 
        404  Not Found</i><i><br>
      </i><i>E: Falhou o download de alguns ficheiros de índice. Foram
        ignorados ou os antigos foram usados em seu lugar.</i></p>
    <p><br>
    </p>
    <p style="margin-bottom:0cm;font-weight:normal;line-height:100%"><font
        color="#999999"><i>Márcio Vilas Boas</i></font><br>
      <font color="#999999"><i>Diretor</i></font><font color="#999999"><i>ia
        </i></font><font color="#999999"><i>de Informática</i></font><br>
      <font color="#999999"><i>CM - Divinópolis - MG</i></font><br>
      <font color="#999999"><i><a href="tel:%2837%29%202102-8236"
            value="+553721028236" target="_blank">(37) 2102-8236</a></i></font></p>
    <br>
    <div class="moz-cite-prefix">Em 22/09/2017 15:34, Angelo Marcondes
      de Oliveira Neto escreveu:<br>
    </div>
    <blockquote type="cite"
cite="mid:CA+PaJRrj61RQB3rJ6NXLh-j4jmNyZcKBY4AYRRtnaSN2UJbFJg@mail.gmail.com">
      <div dir="ltr">Marcio, Fábio e Edward
        <div><br>
        </div>
        <div>Acabei de fazer algumas modificações no roteiro de
          instalação com o docker compose.</div>
        <div><a href="https://colab.interlegis.leg.br/wiki/SAPL31Docker"
            moz-do-not-send="true">https://colab.interlegis.leg.br/wiki/SAPL31Docker</a><br>
        </div>
        <div><br>
        </div>
        <div>Existem alguns detalhes que temos que nos atentar para este
          processo e acho que os deixei claro nas modificações.</div>
        <div><br>
        </div>
        <div>Realizei o processo aqui, em uma VM com o Ubuntu 16.04
          (server) e o mesmo funcionou perfeitamente.</div>
        <div><br>
        </div>
        <div>Vou testar no 14.04 e reporto algum problema a vocês.</div>
        <div><br>
        </div>
        <div>Abraços</div>
        <div><br>
        </div>
        <div><br>
        </div>
      </div>
      <div class="gmail_extra"><br clear="all">
        <div>
          <div class="gmail_signature" data-smartmail="gmail_signature">
            <div dir="ltr">
              <div>
                <div dir="ltr">
                  <div>
                    <div dir="ltr">
                      <div>
                        <div dir="ltr">
                          <div>
                            <div dir="ltr">
                              <div>
                                <div dir="ltr">Angelo Marcondes de
                                  Oliveira Neto.
                                  <div>(34) 9 9141 4287 <br>
                                    Carneirinho - MG
                                    <div><br>
                                    </div>
                                  </div>
                                </div>
                              </div>
                            </div>
                          </div>
                        </div>
                      </div>
                    </div>
                  </div>
                </div>
              </div>
            </div>
          </div>
        </div>
        <br>
        <div class="gmail_quote">Em 22 de setembro de 2017 15:19, Marcio
          Vilas Boas <span dir="ltr"><<a
              href="mailto:marcio@divinopolis.mg.leg.br" target="_blank"
              moz-do-not-send="true">marcio@divinopolis.mg.leg.br</a>></span>
          escreveu:<br>
          <blockquote class="gmail_quote" style="margin:0 0 0
            .8ex;border-left:1px #ccc solid;padding-left:1ex">
            <div text="#000000" bgcolor="#FFFFFF">
              <p>A conclusão que cheguei foi a seguinte, para vocês
                analisarem:</p>
              <p>Para o download do docker-compose não tem bloqueio,
                apenas algum problema para baixar via cURL</p>
              <p>Realizei o download pelo navegador mesmo e movi o
                arquivo para /us/local/bin</p>
              <p>---</p>
              <p>Para instalar o docker, mesmo executando o conteúdo do
                cURL no navegador, no caso a URL <a
                  class="m_1649752095766691115moz-txt-link-freetext"
                  href="https://get.docker.com" target="_blank"
                  moz-do-not-send="true">https://get.docker.com</a> que
                está basicamente executando o script que se encontra na
                página</p>
              <p>e copiando o conteúdo dele para um arquivo local e o
                executando com "sh" dá os erros abaixo, que são todos
                referentes ao repositório do Ubuntu e aparentemente
                nenhum problema com Firewall/Proxy.</p>
              <p><br>
              </p>
              <p><b><i><font size="2"><font face="Verdana, Arial,
                        Helvetica"><span class=""># Executing docker
                          install script, commit: 716f7ca<br>
                          + sh -c apt-get update -qq >/dev/null<br>
                        </span> W: The repository '<a
                          class="m_1649752095766691115moz-txt-link-freetext"
href="http://ppa.launchpad.net/fta/gnome3/ubuntu" target="_blank"
                          moz-do-not-send="true">http://ppa.launchpad.net/fta/<wbr>gnome3/ubuntu</a>
                        xenial Release' does not have a Release file.<br>
                        E: Falhou ao buscar
                        <a
                          class="m_1649752095766691115moz-txt-link-freetext"
href="http://ppa.launchpad.net/fta/gnome3/ubuntu/dists/xenial/main/binary-amd64/Packages"
                          target="_blank" moz-do-not-send="true">http://ppa.launchpad.net/fta/<wbr>gnome3/ubuntu/dists/xenial/<wbr>main/binary-amd64/Packages</a> 
                        404  Not Found<br>
                        E: Falhou o download de alguns ficheiros de
                        índice. Foram ignorados ou os antigos foram
                        usados em seu lugar.<br>
                      </font></font></i></b><br>
              </p>
              <span class=""> <br>
                <p
                  style="margin-bottom:0cm;font-weight:normal;line-height:100%">
                  <font color="#999999"><i>Márcio Vilas Boas</i></font><br>
                  <font color="#999999"><i>Diretor</i></font><font
                    color="#999999"><i>ia </i></font><font
                    color="#999999"><i>de Informática</i></font><br>
                  <font color="#999999"><i>CM - Divinópolis - MG</i></font><br>
                  <font color="#999999"><i>(37) 2102-8236</i></font></p>
                <p
                  style="margin-bottom:0cm;font-weight:normal;line-height:100%"><font
                    color="#999999"><i><br>
                    </i></font></p>
              </span>
              <div>
                <div class="h5">
                  <div class="m_1649752095766691115moz-cite-prefix">Em
                    18/09/2017 18:54, Edward de Oliveira Ribeiro
                    escreveu:<br>
                  </div>
                  <blockquote type="cite">
                    <p><br>
                    </p>
                    <p>O cURL deveria pegar o arquivo. Isso também pode
                      ser problema de conexão de rede. Talvez algum
                      firewall bloqueando...<br>
                    </p>
                    <p><br>
                    </p>
                    <div style="color:rgb(33,33,33)">
                      <hr style="display:inline-block;width:98%">
                      <div id="m_1649752095766691115divRplyFwdMsg"
                        dir="ltr"><font style="font-size:11pt"
                          color="#000000" face="Calibri, sans-serif"><b>De:</b>
                          Marcio Vilas Boas <a
                            class="m_1649752095766691115moz-txt-link-rfc2396E"
                            href="mailto:marcio@divinopolis.mg.leg.br"
                            target="_blank" moz-do-not-send="true"><marcio@divinopolis.mg.leg.br></a><br>
                          <b>Enviado:</b> segunda-feira, 18 de setembro
                          de 2017 13:58<br>
                          <b>Para:</b> Grupo Interlegis de Tecnologia;
                          Edward de Oliveira Ribeiro; Fábio Kaiser
                          Rauber<br>
                          <b>Assunto:</b> Re: [gitec] RES: Sapl3.1
                          docker</font>
                        <div> </div>
                      </div>
                      <div>
                        <p>Ubuntu 16.04, desktop</p>
                        <p>O problema parece ser mesmo de instalação.</p>
                        <p>O comando curl -L <a
                            class="m_1649752095766691115moz-txt-link-freetext"
                            href="https://github" target="_blank"
                            moz-do-not-send="true">https://github</a>......
                          não completa mais.</p>
                        <p>Antes funcionava. Agora não passa desse ponto
                          abaixo</p>
                        <p><br>
                        </p>
                        <br>
                        <div
                          class="m_1649752095766691115moz-cite-prefix">Em
                          16/09/2017 07:58, Edward de Oliveira Ribeiro
                          escreveu:<br>
                        </div>
                        <blockquote type="cite">
                          <pre>Esse parece ser um problema instalação do Docker. Qual a versão do Linux que esta instalada aí? 

Vc tentou rodar sudo docker-compose up ?

______________________________<wbr>__________
De: <a class="m_1649752095766691115moz-txt-link-abbreviated" href="mailto:gitec-bounces@listas.interlegis.gov.br" target="_blank" moz-do-not-send="true">gitec-bounces@listas.<wbr>interlegis.gov.br</a> [<a class="m_1649752095766691115moz-txt-link-abbreviated" href="mailto:gitec-bounces@listas.interlegis.gov.br" target="_blank" moz-do-not-send="true">gitec-bounces@listas.<wbr>interlegis.gov.br</a>] em nome de Marcio Vilas Boas [<a class="m_1649752095766691115moz-txt-link-abbreviated" href="mailto:marcio@divinopolis.mg.leg.br" target="_blank" moz-do-not-send="true">marcio@divinopolis.mg.leg.br</a>]
Enviado: sexta-feira, 15 de setembro de 2017 16:00
Para: Grupo Interlegis de Tecnologia; Fábio Kaiser Rauber
Assunto: Re: [gitec] Sapl3.1 docker

Fabio,

O erro sumiu com o False, porém tem que manter aspas simples.

Um problema maior é que não consigo mais fazer o download, mesmo depois de muitas tentavias. Tanto para o SAPL quanto para o PM3 parou.

Veja o andamento disso e observe que pára sempre no mesmo lugar.

curl -L <a class="m_1649752095766691115moz-txt-link-freetext" href="https://github.com/docker/compose/releases/download/1.13.0/docker-compose" target="_blank" moz-do-not-send="true">https://github.com/docker/<wbr>compose/releases/download/1.<wbr>13.0/docker-compose</a>-`uname -s`-`uname -m` > /usr/local/bin/docker-compose

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   617    0   617    0     0     63      0 --:--:--  0:00:09 --:--:--   144
100 8079k  100 8079k    0     0   286k      0  0:00:28  0:00:28 --:--:--  982k


Consequentemente, quando rodo docker-compose up -d a mesma msg de instalação aparece:

ERROR: Couldn't connect to Docker daemon. You might need to install Docker:

<a class="m_1649752095766691115moz-txt-link-freetext" href="https://docs.docker.com/engine/installation/" target="_blank" moz-do-not-send="true">https://docs.docker.com/<wbr>engine/installation/</a>


att,


Em 15/09/2017 15:14, Fábio Kaiser Rauber escreveu:

Márcio,

O Edward me apontou que, como USE_TLS e DEBUG são booleanos do Python, eles devem começar com letra maiúscula: False. Corrigi no tutorial, esta deve ser a razão correta do erro que você visualizou.

Atenciosamente,

Fabio Kaiser Rauber
Analista de Informática Legislativa
Serviço de Infraestrutura Tecnológica
Interlegis - Senado Federal

<a class="m_1649752095766691115moz-txt-link-abbreviated" href="http://www.interlegis.leg.br" target="_blank" moz-do-not-send="true">www.interlegis.leg.br</a><a class="m_1649752095766691115moz-txt-link-rfc2396E" href="http://www.interlegis.leg.br" target="_blank" moz-do-not-send="true"><http://<wbr>www.interlegis.leg.br></a>

Em 15-09-2017 10:13, Fábio Kaiser Rauber escreveu:

Prezado Márcio,

Tente colocar o false entre aspas simples: 'false'. Se funcionar, nos avise para que possamos modificar no COLAB.

Atenciosamente,

Fabio Kaiser Rauber
Analista de Informática Legislativa
Serviço de Infraestrutura Tecnológica
Interlegis - Senado Federal

<a class="m_1649752095766691115moz-txt-link-abbreviated" href="http://www.interlegis.leg.br" target="_blank" moz-do-not-send="true">www.interlegis.leg.br</a><a class="m_1649752095766691115moz-txt-link-rfc2396E" href="http://www.interlegis.leg.br" target="_blank" moz-do-not-send="true"><http://<wbr>www.interlegis.leg.br></a>

Em 14-09-2017 16:52, Marcio Vilas Boas escreveu:

Fábio, sabe qual  o motivo desse erro ao rodar docker-compose up -d   ?

Copiei o yml da página, não achei para baixar, como tem do PM3. USE_TLS está mesmo como false

ERROR: The Compose file './docker-compose.yml' is invalid because:
sapl.environment.USE_TLS contains false, which is an invalid type, it should be a string, number, or a null

att,


Márcio Vilas Boas
Diretoria de Informática
CM - Divinópolis - MG
<a href="tel:%2837%29%202102-8236" value="+553721028236" target="_blank" moz-do-not-send="true">(37) 2102-8236</a>









--


Márcio Vilas Boas
Diretoria de Informática
CM - Divinópolis - MG
<a href="tel:%2837%29%202102-8236" value="+553721028236" target="_blank" moz-do-not-send="true">(37) 2102-8236</a>

</pre>
                        </blockquote>
                        <br>
                        <div class="m_1649752095766691115moz-signature">--
                          <br>
                          <p style="margin-bottom:0cm;line-height:100%"><br>
                          </p>
                          <p
                            style="margin-bottom:0cm;font-weight:normal;line-height:100%"><font
                              color="#999999"><i>Márcio Vilas Boas</i></font><br>
                            <font color="#999999"><i>Diretor</i></font><font
                              color="#999999"><i>ia </i></font><font
                              color="#999999"><i>de Informática</i></font><br>
                            <font color="#999999"><i>CM - Divinópolis -
                                MG</i></font><br>
                            <font color="#999999"><i><a
                                  href="tel:%2837%29%202102-8236"
                                  value="+553721028236" target="_blank"
                                  moz-do-not-send="true">(37) 2102-8236</a></i></font></p>
                        </div>
                      </div>
                    </div>
                  </blockquote>
                  <br>
                </div>
              </div>
              <div class="m_1649752095766691115moz-signature">-- <br>
                <p style="margin-bottom:0cm;line-height:100%"><br>
                </p>
                <p
                  style="margin-bottom:0cm;font-weight:normal;line-height:100%">
                  <br>
                </p>
              </div>
            </div>
            <br>
            --<br>
            Histórico do grupo:<br>
            <a
href="http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=gitec"
              rel="noreferrer" target="_blank" moz-do-not-send="true">http://colab.interlegis.leg.<wbr>br/search/?type=thread&order=<wbr>latest&list=gitec</a><br>
            <br>
            Regras de participação:<br>
            <a
              href="http://colab.interlegis.leg.br/wiki/ComoParticiparComunidade"
              rel="noreferrer" target="_blank" moz-do-not-send="true">http://colab.interlegis.leg.<wbr>br/wiki/<wbr>ComoParticiparComunidade</a><br>
            <br>
            Para administrar ou excluir sua conta visite:<br>
            <a
              href="https://listas.interlegis.gov.br/mailman/listinfo/gitec"
              rel="noreferrer" target="_blank" moz-do-not-send="true">https://listas.interlegis.gov.<wbr>br/mailman/listinfo/gitec</a><br>
          </blockquote>
        </div>
        <br>
      </div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
    </blockquote>
    <br>
    <div class="moz-signature">-- <br>
      <meta http-equiv="content-type" content="text/html; charset=utf-8">
      <title></title>
      <meta name="generator" content="LibreOffice 5.4.0.3 (Linux)">
      <meta name="created" content="2017-09-14T16:52:12.815453666">
      <meta name="changed" content="2017-09-14T16:59:01.696965878">
      <style type="text/css">
                @page { margin: 2cm }
                p { margin-bottom: 0.25cm; line-height: 120% }
                a:link { so-language: zxx }
        </style>
      <p style="margin-bottom: 0cm; line-height: 100%"><br>
      </p>
      <p style="margin-bottom: 0cm; font-weight: normal; line-height:
        100%">
        <font color="#999999"><i>Márcio Vilas Boas</i></font><br>
        <font color="#999999"><i>Diretor</i></font><font color="#999999"><i>ia
          </i></font><font color="#999999"><i>de Informática</i></font><br>
        <font color="#999999"><i>CM
            - Divinópolis - MG</i></font><br>
        <font color="#999999"><i>(37)
            2102-8236</i></font></p>
    </div>
  </body>
</html>