[gitec] RES: Sapl3.1 docker

Marcio Vilas Boas marcio em divinopolis.mg.leg.br
Quarta Setembro 27 13:33:38 BRT 2017


Acesso local pode ser localhost ou 127.0.0.1 e remoto o IP da máquina 
que foi feita a instalação.

abs,


/Márcio Vilas Boas/
/Diretor//ia //de Informática/
/CM - Divinópolis - MG/
/(37) 2102-8236 <tel:%2837%29%202102-8236>/


Em 26/09/2017 16:29, Luis Carlos Sponhardi escreveu:
>
> Qual IP Márcio?
>
>
> *LUIS CARLOS SPONHARDI *
>
> *INTERARES - SUPORTE E CONSULTORIA EM INFORMÁTICA*
>
> *CEP: 14840-000 - Guariba/SP
> Celular: +55 (16) 99752-9743
> E-Mail: luis em vuptnet.com.br
> SKYPE: luissponhardi em hotmail.com*
>
>
>
> ------------------------------------------------------------------------
> *De:* gitec-bounces em listas.interlegis.gov.br 
> <gitec-bounces em listas.interlegis.gov.br> em nome de Marcio Vilas Boas 
> <marcio em divinopolis.mg.leg.br>
> *Enviado:* terça-feira, 26 de setembro de 2017 14:47
> *Para:* Grupo Interlegis de Tecnologia; Angelo Marcondes de Oliveira Neto
> *Assunto:* Re: [gitec] RES: Sapl3.1 docker
>
> Pessoal, resolvido!
>
> Depois de tanto tentar usar /curl -ssl https://get.docker.com | sh 
> para instalar o docker, o que estava dando problemas com repositórios 
> ubuntu, mesmo desmarcando do source.list,/
>
> /
> Docker <https://get.docker.com/>
> get.docker.com
> #!/bin/sh set -e # This script is meant for quick & easy install via: 
> # $ curl -fsSL get.docker.com -o get-docker.sh # $ sh get-docker.sh # 
> # For test builds (ie ...
>
>
>
> /
>
> /usei simplesmente //*apt install docker.io* e instalou tudo numa boa 
> e já estou com o SAPL31 no ar !/
>
> /Para acessar: IP:80 usuario: admin  senha: interlegis
> /
>
> /abs,/
>
>
> //Márcio Vilas Boas/
> /Diretor//ia //de Informática/
> /CM - Divinópolis - MG/
> /(37) 2102-823/ /
>
>
> Em 25/09/2017 14:47, Marcio Vilas Boas escreveu:
>>
>> Pois é , mas aqui, mesmo observando  todos detalhes, os erros de 
>> instalação são referentes ao repositórios do Ubuntu, vejam;
>>
>> /curl -ssl https://get.docker.com | sh/
>>
>> Docker <https://get.docker.com/>
>> get.docker.com
>> #!/bin/sh set -e # This script is meant for quick & easy install via: 
>> # $ curl -fsSL get.docker.com -o get-docker.sh # $ sh get-docker.sh # 
>> # For test builds (ie ...
>>
>>
>> /
>> //# Executing docker install script, commit: 716f7ca//
>> //+ sh -c apt-get update -qq >/dev/null//
>> //W: The repository 'http://ppa.launchpad.net/fta/gnome3/ubuntu 
>> xenial Release' does not have a Release file.//
>> //E: Falhou ao buscar 
>> http://ppa.launchpad.net/fta/gnome3/ubuntu/dists/xenial/main/binary-amd64/Packages 
>> 404  Not Found//
>> //E: Falhou o download de alguns ficheiros de índice. Foram ignorados 
>> ou os antigos foram usados em seu lugar./
>>
>>
>> /Márcio Vilas Boas/
>> /Diretor//ia //de Informática/
>> /CM - Divinópolis - MG/
>> /(37) 2102-8236 <tel:%2837%29%202102-8236>/
>>
>>
>> Em 22/09/2017 15:34, Angelo Marcondes de Oliveira Neto escreveu:
>>> Marcio, Fábio e Edward
>>>
>>> Acabei de fazer algumas modificações no roteiro de instalação com o 
>>> docker compose.
>>> https://colab.interlegis.leg.br/wiki/SAPL31Docker
>>>
>>> Existem alguns detalhes que temos que nos atentar para este processo 
>>> e acho que os deixei claro nas modificações.
>>>
>>> Realizei o processo aqui, em uma VM com o Ubuntu 16.04 (server) e o 
>>> mesmo funcionou perfeitamente.
>>>
>>> Vou testar no 14.04 e reporto algum problema a vocês.
>>>
>>> Abraços
>>>
>>>
>>>
>>> Angelo Marcondes de Oliveira Neto.
>>> (34) 9 9141 4287
>>> Carneirinho - MG
>>>
>>>
>>> Em 22 de setembro de 2017 15:19, Marcio Vilas Boas 
>>> <marcio em divinopolis.mg.leg.br <mailto:marcio em divinopolis.mg.leg.br>> 
>>> escreveu:
>>>
>>>     A conclusão que cheguei foi a seguinte, para vocês analisarem:
>>>
>>>     Para o download do docker-compose não tem bloqueio, apenas algum
>>>     problema para baixar via cURL
>>>
>>>     Realizei o download pelo navegador mesmo e movi o arquivo para
>>>     /us/local/bin
>>>
>>>     ---
>>>
>>>     Para instalar o docker, mesmo executando o conteúdo do cURL no
>>>     navegador, no caso a URL https://get.docker.com
>>>     <https://get.docker.com> que está basicamente executando o
>>>     script que se encontra na página
>>>
>>>     e copiando o conteúdo dele para um arquivo local e o executando
>>>     com "sh" dá os erros abaixo, que são todos referentes ao
>>>     repositório do Ubuntu e aparentemente nenhum problema com
>>>     Firewall/Proxy.
>>>
>>>
>>>     */# Executing docker install script, commit: 716f7ca
>>>     + sh -c apt-get update -qq >/dev/null
>>>     W: The repository 'http://ppa.launchpad.net/fta/gnome3/ubuntu
>>>     <http://ppa.launchpad.net/fta/gnome3/ubuntu> xenial Release'
>>>     does not have a Release file.
>>>     E: Falhou ao buscar
>>>     http://ppa.launchpad.net/fta/gnome3/ubuntu/dists/xenial/main/binary-amd64/Packages
>>>     <http://ppa.launchpad.net/fta/gnome3/ubuntu/dists/xenial/main/binary-amd64/Packages>
>>>     404  Not Found
>>>     E: Falhou o download de alguns ficheiros de índice. Foram
>>>     ignorados ou os antigos foram usados em seu lugar.
>>>     /*
>>>
>>>
>>>     /Márcio Vilas Boas/
>>>     /Diretor//ia //de Informática/
>>>     /CM - Divinópolis - MG/
>>>     /(37) 2102-8236/
>>>
>>>     /
>>>     /
>>>
>>>     Em 18/09/2017 18:54, Edward de Oliveira Ribeiro escreveu:
>>>>
>>>>
>>>>     O cURL deveria pegar o arquivo. Isso também pode ser problema
>>>>     de conexão de rede. Talvez algum firewall bloqueando...
>>>>
>>>>
>>>>     ------------------------------------------------------------------------
>>>>     *De:* Marcio Vilas Boas <marcio em divinopolis.mg.leg.br>
>>>>     <mailto:marcio em divinopolis.mg.leg.br>
>>>>     *Enviado:* segunda-feira, 18 de setembro de 2017 13:58
>>>>     *Para:* Grupo Interlegis de Tecnologia; Edward de Oliveira
>>>>     Ribeiro; Fábio Kaiser Rauber
>>>>     *Assunto:* Re: [gitec] RES: Sapl3.1 docker
>>>>
>>>>     Ubuntu 16.04, desktop
>>>>
>>>>     O problema parece ser mesmo de instalação.
>>>>
>>>>     O comando curl -L https://github <https://github>...... não
>>>>     completa mais.
>>>>
>>>>     Antes funcionava. Agora não passa desse ponto abaixo
>>>>
>>>>
>>>>
>>>>     Em 16/09/2017 07:58, Edward de Oliveira Ribeiro escreveu:
>>>>>     Esse parece ser um problema instalação do Docker. Qual a versão do Linux que esta instalada aí?
>>>>>
>>>>>     Vc tentou rodar sudo docker-compose up ?
>>>>>
>>>>>     ________________________________________
>>>>>     De:gitec-bounces em listas.interlegis.gov.br
>>>>>     <mailto:gitec-bounces em listas.interlegis.gov.br>  [gitec-bounces em listas.interlegis.gov.br
>>>>>     <mailto:gitec-bounces em listas.interlegis.gov.br>] em nome de Marcio Vilas Boas [marcio em divinopolis.mg.leg.br <mailto:marcio em divinopolis.mg.leg.br>]
>>>>>     Enviado: sexta-feira, 15 de setembro de 2017 16:00
>>>>>     Para: Grupo Interlegis de Tecnologia; Fábio Kaiser Rauber
>>>>>     Assunto: Re: [gitec] Sapl3.1 docker
>>>>>
>>>>>     Fabio,
>>>>>
>>>>>     O erro sumiu com o False, porém tem que manter aspas simples.
>>>>>
>>>>>     Um problema maior é que não consigo mais fazer o download, mesmo depois de muitas tentavias. Tanto para o SAPL quanto para o PM3 parou.
>>>>>
>>>>>     Veja o andamento disso e observe que pára sempre no mesmo lugar.
>>>>>
>>>>>     curl -Lhttps://github.com/docker/compose/releases/download/1.13.0/docker-compose
>>>>>     <https://github.com/docker/compose/releases/download/1.13.0/docker-compose>-`uname -s`-`uname -m` > /usr/local/bin/docker-compose
>>>>>
>>>>>        % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
>>>>>                                       Dload  Upload   Total   Spent    Left  Speed
>>>>>     100   617    0   617    0     0     63      0 --:--:--  0:00:09 --:--:--   144
>>>>>     100 8079k  100 8079k    0     0   286k      0  0:00:28  0:00:28 --:--:--  982k
>>>>>
>>>>>
>>>>>     Consequentemente, quando rodo docker-compose up -d a mesma msg de instalação aparece:
>>>>>
>>>>>     ERROR: Couldn't connect to Docker daemon. You might need to install Docker:
>>>>>
>>>>>     https://docs.docker.com/engine/installation/
>>>>>     <https://docs.docker.com/engine/installation/>
>>>>>
>>>>>
>>>>>     att,
>>>>>
>>>>>
>>>>>     Em 15/09/2017 15:14, Fábio Kaiser Rauber escreveu:
>>>>>
>>>>>     Márcio,
>>>>>
>>>>>     O Edward me apontou que, como USE_TLS e DEBUG são booleanos do Python, eles devem começar com letra maiúscula: False. Corrigi no tutorial, esta deve ser a razão correta do erro que você visualizou.
>>>>>
>>>>>     Atenciosamente,
>>>>>
>>>>>     Fabio Kaiser Rauber
>>>>>     Analista de Informática Legislativa
>>>>>     Serviço de Infraestrutura Tecnológica
>>>>>     Interlegis - Senado Federal
>>>>>
>>>>>     www.interlegis.leg.br
>>>>>     <http://www.interlegis.leg.br><http://www.interlegis.leg.br>
>>>>>     <http://www.interlegis.leg.br>
>>>>>
>>>>>     Em 15-09-2017 10:13, Fábio Kaiser Rauber escreveu:
>>>>>
>>>>>     Prezado Márcio,
>>>>>
>>>>>     Tente colocar o false entre aspas simples: 'false'. Se funcionar, nos avise para que possamos modificar no COLAB.
>>>>>
>>>>>     Atenciosamente,
>>>>>
>>>>>     Fabio Kaiser Rauber
>>>>>     Analista de Informática Legislativa
>>>>>     Serviço de Infraestrutura Tecnológica
>>>>>     Interlegis - Senado Federal
>>>>>
>>>>>     www.interlegis.leg.br
>>>>>     <http://www.interlegis.leg.br><http://www.interlegis.leg.br>
>>>>>     <http://www.interlegis.leg.br>
>>>>>
>>>>>     Em 14-09-2017 16:52, Marcio Vilas Boas escreveu:
>>>>>
>>>>>     Fábio, sabe qual  o motivo desse erro ao rodar docker-compose up -d   ?
>>>>>
>>>>>     Copiei o yml da página, não achei para baixar, como tem do PM3. USE_TLS está mesmo como false
>>>>>
>>>>>     ERROR: The Compose file './docker-compose.yml' is invalid because:
>>>>>     sapl.environment.USE_TLS contains false, which is an invalid type, it should be a string, number, or a null
>>>>>
>>>>>     att,
>>>>>
>>>>>
>>>>>     Márcio Vilas Boas
>>>>>     Diretoria de Informática
>>>>>     CM - Divinópolis - MG
>>>>>     (37) 2102-8236 <tel:%2837%29%202102-8236>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>     --
>>>>>
>>>>>
>>>>>     Márcio Vilas Boas
>>>>>     Diretoria de Informática
>>>>>     CM - Divinópolis - MG
>>>>>     (37) 2102-8236 <tel:%2837%29%202102-8236>
>>>>>
>>>>
>>>>     -- 
>>>>
>>>>
>>>>     /Márcio Vilas Boas/
>>>>     /Diretor//ia //de Informática/
>>>>     /CM - Divinópolis - MG/
>>>>     /(37) 2102-8236 <tel:%2837%29%202102-8236>/
>>>>
>>>
>>>     -- 
>>>
>>>
>>>
>>>
>>>     --
>>>     Histórico do grupo:
>>>     http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=gitec
>>>     <http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=gitec>
>>>
>>>     Regras de participação:
>>>     http://colab.interlegis.leg.br/wiki/ComoParticiparComunidade
>>>     <http://colab.interlegis.leg.br/wiki/ComoParticiparComunidade>
>>>
>>>     Para administrar ou excluir sua conta visite:
>>>     https://listas.interlegis.gov.br/mailman/listinfo/gitec
>>>     <https://listas.interlegis.gov.br/mailman/listinfo/gitec>
>>>
>>>
>>>
>>>
>>
>> -- 
>>
>>
>> /Márcio Vilas Boas/
>> /Diretor//ia //de Informática/
>> /CM - Divinópolis - MG/
>> /(37) 2102-8236/
>>
>>
>>
>
> -- 
>
>
> /Márcio Vilas Boas/
> /Diretor//ia //de Informática/
> /CM - Divinópolis - MG/
> /(37) 2102-8236/
>
>
>

-- 


/Márcio Vilas Boas/
/Diretor//ia //de Informática/
/CM - Divinópolis - MG/
/(37) 2102-8236/

-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/gitec/attachments/20170927/5407f34b/attachment.html>


Mais detalhes sobre a lista de discussão GITEC