[gitec] Docker-compose

Fábio Kaiser Rauber fabior em interlegis.leg.br
Quinta Agosto 10 08:44:22 BRT 2017


Prezado Alessandro,

O seu arquivo docker-compose deve ter, exatamente, o seguinte conteúdo:

version: '2'
services:
   plone:
     image: interlegis/portalmodelo:3.0-4
     environment:
       ZEO_ADDRESS: zeoserver:8100
       ZEO_SHARED_BLOB_DIR: 'on'
     command: fg
     depends_on:
       - zeoserver
     volumes:
       - data:/data
     ports:
       - 8080:8080
   zeoserver:
     image: interlegis/portalmodelo:3.0-4
     command: zeoserver
     environment:
       ZEO_SHARED_BLOB_DIR: 'on'
     volumes:
       - data:/data
volumes:
   data:
     driver: local

Se desejar, você pode baixar este arquivo com o seguinte comando:

wget 
https://github.com/interlegis/interlegis.portalmodelo.docker/raw/master/docker-compose.yml

Com relação ao arquivo do Portal, o próprio Docker se encarregará de 
baixar uma imagem do Portal Modelo para execução.


Qualquer dúvida estamos à disposição.

Atenciosamente,

*Fabio Kaiser Rauber*

Analista de Informática Legislativa *
*Serviço de Infraestrutura Tecnológica
Interlegis - Senado Federal

*www.interlegis.leg.br <http://www.interlegis.leg.br>*

Em 09-08-2017 14:53, suporte em divinopolis.mg.leg.br escreveu:
> Prezados,
>
> boa tarde.
>
> estou tentando usar docker local para usar o portal modelo, minha máquina
> esta com ubuntu 16.04.
>
> estou seguindo os procedimentos conforme link abaixo:
>
> https://colab.interlegis.leg.br/wiki/PortalModelo30Docker?version=8
>
> Os itens abaixo transcorreram perfeitamente:
> 1) Instalar o Docker
> 2) Instalar o Docker compose:
> 3) Criar o arquivo docker-compose.yml
> 4) Entrar na pasta onde o arquivo foi criado:
>
> Porem no item 5 tive um problema e não consegui ir para frente:
> 5) Rodar o Docker compose:
>
> conforme comando abaixo deu as mensagens de erro, alguém teve este
> problema e poderia ajudar?
> docker-compose up -d
> /usr/local/bin/docker-compose: linha 1: erro de sintaxe próximo do `token'
> não esperado `newline'
> /usr/local/bin/docker-compose: linha 1: `<!DOCTYPE html>'
>
> Uma coisa que não ficou clara no roteiro de instalação é que pelo que
> entendi tenho que ter um arquivo do portal para rodar, porem lá não tem o
> link de qual arquivo devo baixar.
>
> Já refiz o procedimento, mas sempre para no mesmo ponto.
>
> Desde já agradeço a ajuda e aguardo.
>
> Alexsandro Vasconcelos
> CM - Divinópolis - MG
> 37 - 2102-8258
>

-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/gitec/attachments/20170810/9280ea34/attachment.html>


Mais detalhes sobre a lista de discussão GITEC