[gitec] Erro migração Sapl 2.2 para Sapl 2.5

Gustavo Lepri gustavolepri em gmail.com
Segunda Fevereiro 23 10:29:01 BRT 2015


Olá Rodrigo,

Esse erro parece ser em relação ao mount point do sapl_documento.
Experimente removê-lo e adicioná-lo manualmente.

[]'s
Gustavo Lepri

2015-02-21 13:10 GMT-02:00 Rodrigo de Almeida Américo Americo <
americo.rodrigo em gmail.com>:

> Boa tarde, pessoal!
>
>
> Fiz todos o passos para migrar o sapl2.2 para o sapl 2.5 e funcionou
> normalmente, porém hoje quando fui fazer somente a migração de dados, ou
> seja, a cópia dos DocumentosSapl.fs, Data.fs e do banco de dados, quando
> rodei entrei na url do sapl, no meu caso (
> http://www.camarasorocaba.sp.gov.br:8080/sapl) deu a seguinte mensagem de
> erro:
>
>
> *Site Error*
>
> An error was encountered while publishing this resource.
>
> *AttributeError*
>
> (Also, the following error occurred while attempting to render the
> standard error message, please see the event log for full details:
> props_sapl)Traceback (innermost last): Module ZPublisher.Publish, line 196,
> in publish_module_standard Module ZPublisher.Publish, line 146, in publish
> Module Zope2.App.startup, line 222, in zpublisher_exception_hook Module
> ZPublisher.Publish, line 115, in publish Module ZPublisher.mapply, line 88,
> in mapply Module ZPublisher.Publish, line 41, in call_object Module
> Products.CMFCore.FSDTMLMethod, line 133, in __call__ - __traceback_info__:
> ILSAPL/skins/sk_sapl/sapl_skin_index_html.dtml Module
> DocumentTemplate.DT_String, line 476, in __call__ Module
> Products.CMFCore.FSDTMLMethod, line 133, in __call__ - __traceback_info__:
> ILSAPL/skins/sk_sapl/standard_html_header.dtml Module
> DocumentTemplate.DT_String, line 476, in __call__ Module
> Products.CMFCore.FSDTMLMethod, line 133, in __call__ - __traceback_info__:
> ILSAPL/skins/sk_sapl/standard_html_top_bar.dtml Module
> DocumentTemplate.DT_String, line 476, in __call__ Module
> DocumentTemplate.DT_Let, line 76, in render Module
> DocumentTemplate.DT_Util, line 196, in eval - __traceback_info__: REQUEST
> Module , line 1, inAttributeError: (see above)
>
>
>
> Entrando na ZMI, percebi que o na raiz, em sapl_documentos, o ícone estava
> com o descenho de um quadrado partido ao meio e um sinal de interrogação
> entre eles.
>
> Cliquei no ícone e foi exibida a seguinte mensagem:
>
>
> Site Error
>
> An error was encountered while publishing this resource.
>
> *Error Type: TypeError*
> *Error Value: unbound method __str__() must be called with
> ConfigurationError instance as first argument (got nothing instead)*
>
>
>
> Por favor, se alguém tiver uma dica ou um caminho para eu resolver este
> problema será de grande ajuda para eu poder fazer esta migração.
>
>
>
> Abraços,
>
>
>
> Rodrigo Américo
>
> Analista de Sistemas
>
> Câmara Municipal de Sorocaba
>
> --
> Histórico do grupo:
> http://colab.interlegis.leg.br/search/?type=thread&order=latest&list=gitec
>
> Regras de participação:
> http://colab.interlegis.leg.br/wiki/ComoParticiparComunidade
>
> Para administrar ou excluir sua conta visite:
> https://listas.interlegis.gov.br/mailman/listinfo/gitec
>



-- 
Gustavo Lepri
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: <http://listas.interlegis.gov.br/pipermail/gitec/attachments/20150223/b828ca30/attachment.html>


Mais detalhes sobre a lista de discussão GITEC