[gitec] SPDO não instala

celso magela de almeida celso em pocosdecaldas.mg.leg.br
Sexta Junho 21 11:08:40 BRT 2013


Vamos solicitar a ajuda dos experts em ZOPE/PLONE...

Estou com problemas de instalação do SPDO.


Xiru,

por favor, não solicitaria a ajuda sem tentar exaustivamente resolver os
problemas antes de lhe incomodar.

Você deve se lembrar do erro que o meu SPDO estava apresentando ha algum
tempo.  Você estava viajando e acabei resolvendo  antes de sua chegada ao
Brasil.

Resolvi isso criando OUTRA máquina virtual à partir do ISO disponível e
importando a base de dados. A instalação à partir da ISO funciona
perfeitamente, mas a versão do ubuntu é 10.04 e o HD de 100Gb.

Meu problema é que criando a máquina de 100GB, eu não posso usar no meu
servidor de virtualização. Para resolver isso, criei-a em meu VirtualBox e,
usando o remastersys, criei um instalador que pode ser instalado em
qualquer máquina à partir do zero, inclusive escolhendo tamanho de hd
diferente, para depois exportar para o servidor(ubuntu 10.04 mesmo).   A
instalação acontece normalmente, mas após a instalação no servidor, o erro
acontece sempre da mesma forma.  Fiz o mesmo procedimento várias vezes sem
êxito.

Sem me render, resolvi usar o instalador:

wget -O - http://repositorio.interlegis.gov.br/il.spdo/trunk/docs/install-spdo.sh
| sh  (em uma nova máquina ubuntu 12.04server)

para isso, instalei uma versão do Ubuntu 12.04 server, atualizei-o,
preparei as configurações de proxy e executei a linha acima.
A instalação acontece até o final (inclusive com a fase de download do
plone), mas eu não consigo acessar a aplicação. Chequei o log da instalação
( /tmp/spdo-install.log) e percebi que o Plone, apesar de ter baixado
integralmente durante a instalação, apresentou um erro "erro ao tentar
baixar o instalador do Plone".   BAIXEI o plone por fora e fiz a instalação
antes de tudo, com o usuario "admin" e a senha "interlegis" esperando que
na próxima instalação do SPDO não efetuasse a tentativa de instalar o plone
novamente. (http://herson.objectis.net/artigos/instalando-plone-4-no-ubuntu)


Executei o comando de novo e ele faz o download do plone novamente,
terminou a instalação, mas apresenta o mesmo erro no log.

Não sei o que fazer. Preciso da instalação em uma máquina UBUNTU 12.04 e
com 50GB de HD

abaixo, o erro apresentado na máquina criada apos o remastersys:


quando eu executei o ./bin/buildout -c develop.cfg,  apareceu o erro de
novo :

./bin/buildout -c develop.cfg

...

  File "/usr/lib/python2.6/httplib.
py", line 78, in <module>
    import mimetools
  File "/usr/lib/python2.6/mimetools.py", line 6, in <module>
    import tempfile
  File "/usr/lib/python2.6/tempfile.py", line 34, in <module>
    from random import Random as _Random
  File "/usr/lib/python2.6/random.py", line 47, in <module>
    from os import urandom as _urandom
ImportError: cannot import name urandom"


Celso Magela de Almeida
Assessor TI
Câmara Municipal de Poços de Caldas - MG
www.pocosdecaldas.mg.leg.br
35 - 3729-3840 - 8805-7054


*-- Por que esta mensagem é tão curta?   --  **Resposta:
http://3frases.efetividade.net* <http://3frases.efetividade.net>*  --*



Em 13 de junho de 2013 19:48, Comercial
<comercial em cgcomsistemas.com.br>escreveu:

>  Oi Pessoal****
>
> ** **
>
> Sou Carlos Oliveira, da Câmara de Vereadores de Venâncio Aires, RS.****
>
> ** **
>
> Estamos implantando aqui o SAPL, SPDO e estou precisando de ajuda para
> instalar, já fiz 3 tentativas e não estou conseguindo rodar.****
>
> ** **
>
> Me indiquem alguém para quem eu possa pedir ajuda.****
>
> ** **
>
> Obrigado****
>
> msn: cgsuporte em hotmail.com****
>
> email cgsuporte em hotmail.com****
>
> ** **
>
> ** **
>
>  --
> Site da Comunidade GITEC:
> http://colab.interlegis.leg.br
>
> Regras de participação:
> http://colab.interlegis.leg.br/wiki/ComoParticiparComunidade
>
> Para pesquisar o histórico da lista visite:
> http://colab.interlegis.leg.br/wiki/PesquisaListas
>
> Para administrar ou excluir sua conta visite:
> http://listas.interlegis.gov.br/mailman/listinfo/gitec
>
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: http://listas.interlegis.gov.br/pipermail/gitec/attachments/20130621/d68ec3a5/attachment.htm 


Mais detalhes sobre a lista de discussão GITEC