[gitec] Erro Matérias Expediente!!!

Claudio Morale claudiomorale em interlegis.leg.br
Segunda Julho 2 19:47:25 BRT 2012


Neybson, a revisão 6589 corrige esse problema.

att.

Em 01-07-2012 14:48, Neybson Pires escreveu:
>
>
> Quando eu clico numa pauta em que não tinha matérias do expediente, ele gera a pauta normalmente, porém quando há matérias, ele dá a mensagem: Houve um erro!
> From: neybson em hotmail.com
> To: gitec em listas.interlegis.gov.br
> Date: Sun, 1 Jul 2012 17:42:35 +0000
> Subject: Re: [gitec] Erro Matérias Expediente!!!
>
>
>
>
>
> Morale,
> O procedimento funcionou (menos o item 4), porém quando eu acesso a Pauta ou o resumo da Sessão Plenária ele dá a mensagem: Houve um erro!, mas quando acesso a sessão plenário logado, visito todas as abas normalmente, somente o resumo e a pauta dão a mensagem!!!
> Neybson Pires
>
>> Date: Fri, 29 Jun 2012 14:50:13 -0300
>> From: claudiomorale em interlegis.leg.br
>> To: gitec em listas.interlegis.gov.br
>> Subject: Re: [gitec] Erro Matérias Expediente!!!
>>
>> Olá Neybson,
>>
>> foi detectado um problema na versão 2.4, com a divisão
>> da ordem do dia para matérias do expediente, que se propagou para a
>> 2.5 e segue abaixo a correção.
>>
>> 1) realizar as alterações na versão 2.5, as quais deverão ser
>> atualizadas utilizando o comando svn update. Também, os seguintes
>> procedimentos devem ser executados em relação ao banco de dados:
>>
>> 2) Acesse o mysql, num terminal shell, digite: sudo mysql -u root -p
>>
>> 3) digite: use interlegis;
>>
>> 4) alter table expediente_materia change column cod_ordem cod_ordem_exp
>> int(11) auto_increment;
>>
>> 5) alter table registro_votacao add column cod_ordem_exp int(11)
>> default 0;
>>
>> 6) alter table registro_votacao modify column cod_ordem int(11)
>> default 0;
>>
>> 7) alter table registro_votacao add foreign key fk_expediente_materia
>> (cod_ordem_exp) references expediente_materia(cod_ordem_exp) on delete
>> cascade;
>>
>> 8) update registro_votacao set cod_ordem_exp=cod_ordem;
>>
>> abraço
>>
>> Em 29-06-2012 14:01, Neybson Pires escreveu:
>>>
>>> Olá pessoal,
>>> fiz a última atualização pelo svn (6578) e quando reiniciei o ZOPE começou a dar vários erros. Consertei quase todos, mas este aqui está persistindo, quando acesso a Sessão Plenária e a Pauta das Sessões dá menagem de erro, aí eu me logo e quando acesso a sessão plenária e clico em "Matérias Expediente" ele dá o seguinte erro:
>>> Zope ErrorZope encontrou um erro ao publicar esta página.Tipo do Erro: OperationalError
>>> Valor do Erro: (1054, "Unknown column 'registro_votacao.cod_ordem_exp' in 'on clause'")
>>> Tente executar novamente a operação que ocasionou o erro, verificando se você seguiu corretamente o procedimento. Se o erro continuar, contate os responsáveis pelo sistema (Imprima esta tela para poder comunicar melhor o problema). Obrigado por sua paciência.
>>> Alguém pode me ajudar!!!
>>> NEYBSON PIRESCâmara Municipal de Fortaleza 		 	   		
>>>
>>>
>>>
>>
>>
>> --
>> Claudio Morale
>> Analista de Sistemas
>> Interlegis - Brasília (DF)
>> --
>> Site da Comunidade GITEC:
>> http://colab.interlegis.leg.br
>>
>> Regras de participação:
>> http://colab.interlegis.leg.br/wiki/ComoParticiparComunidade
>>
>> Para pesquisar o histórico da lista visite:
>> http://colab.interlegis.leg.br/wiki/PesquisaListas
>>
>> Para administrar sua conta visite:
>> http://listas.interlegis.gov.br/mailman/listinfo/gitec
>   		 	   		
>
>
>
>


-- 
Claudio Morale
Analista de Sistemas
Interlegis - Brasília (DF)


Mais detalhes sobre a lista de discussão GITEC