[gitec] Erro no portal

Fábio Fischer fabio.fschr em gmail.com
Quarta Abril 13 09:45:14 BRT 2011


Bom dia
Acordei hoje com esse erro no portal.


Site Error

An error was encountered while publishing this resource.

*KeyError*
Sorry, a site error occurred.

Traceback (innermost last):

   - Module ZPublisher.Publish, line 196, in publish_module_standard
   - Module Products.PlacelessTranslationService.PatchStringIO, line 34, in
   new_publish
   - Module ZPublisher.Publish, line 146, in publish
   - Module Zope2.App.startup, line 222, in zpublisher_exception_hook
   - Module ZPublisher.Publish, line 115, in publish
   - Module ZPublisher.mapply, line 88, in mapply
   - Module ZPublisher.Publish, line 41, in call_object
   - Module Shared.DC.Scripts.Bindings, line 311, in __call__
   - Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
   - Module Products.CMFCore.FSPageTemplate, line 195, in _exec
   - Module Products.CacheSetup.patch_cmf, line 50, in FSPT_pt_render
   - Module Products.CacheSetup.patch_cmf, line 116, in PT_pt_render
   *<FSPageTemplate at /portal/pagina-inicial>*
   - Module TAL.TALInterpreter, line 238, in __call__
   - Module TAL.TALInterpreter, line 281, in interpret
   - Module TAL.TALInterpreter, line 749, in do_useMacro
   - Module TAL.TALInterpreter, line 281, in interpret
   - Module TAL.TALInterpreter, line 457, in do_optTag_tal
   - Module TAL.TALInterpreter, line 442, in do_optTag
   - Module TAL.TALInterpreter, line 437, in no_tag
   - Module TAL.TALInterpreter, line 281, in interpret
   - Module TAL.TALInterpreter, line 457, in do_optTag_tal
   - Module TAL.TALInterpreter, line 442, in do_optTag
   - Module TAL.TALInterpreter, line 437, in no_tag
   - Module TAL.TALInterpreter, line 281, in interpret
   - Module TAL.TALInterpreter, line 735, in do_useMacro
   - Module Products.PageTemplates.TALES, line 221, in evaluate
   *URL: /portal/main_template*
   *Line 195, Column 8*
   *Expression: standard:'here/footer/macros/portal_footer'*
   *Names:*

   {'container': <PloneSite at /portal>,
    'context': <PloneSite at /portal>,
    'default': <Products.PageTemplates.TALES.Default instance at 0xb687274c>,
    'here': <PloneSite at /portal>,
    'loop': <Products.PageTemplates.TALES.SafeMapping object at 0xd4b2f8c>,
    'modules': <Products.PageTemplates.ZRPythonExpr._SecureModuleImporter
instance at 0xb689836c>,
    'nothing': None,
    'options': {'args': ()},
    'repeat': <Products.PageTemplates.TALES.SafeMapping object at 0xd4b2f8c>,
    'request': <HTTPRequest, URL=http://192.168.0.2/pagina-inicial>,
    'root': <Application at >,
    'template': <FSPageTemplate at /portal/pagina-inicial>,
    'traverse_subpath': [],
    'user': <SpecialUser 'Anonymous User'>}

   - Module Products.PageTemplates.Expressions, line 185, in __call__
   - Module Products.PageTemplates.Expressions, line 173, in _eval
   - Module Products.PageTemplates.Expressions, line 127, in _eval
   __traceback_info__: here
   - Module Products.PageTemplates.Expressions, line 320, in
   restrictedTraverse
   __traceback_info__: {'path': ['footer', 'macros', 'portal_footer'],
   'TraversalRequestNameStack': []}

KeyError: 'portal_footer' (Also, the following error occurred while
attempting to render the standard error message, please see the event log
for full details: 'portal_footer')

------------------------------

Troubleshooting Suggestions

   - The URL may be incorrect.
   - The parameters passed to this resource may be incorrect.
   - A resource that this resource relies on may be encountering an error.

For more detailed information about the error, please refer to the error
log.

If the error persists please contact the site maintainer. Thank you for your
patience.
Alguém já teve o mesmo problema?

-- 
Fábio Fischer
-------------- Próxima Parte ----------
Um anexo em HTML foi limpo...
URL: http://listas.interlegis.gov.br/pipermail/gitec/attachments/20110413/3a0f604e/attachment.htm 


Mais detalhes sobre a lista de discussão GITEC