[gitec] Erro Comissões

Claudio Morale claudiomorale em interlegis.gov.br
Quinta Agosto 26 11:23:24 BRT 2010


Herbert, basta fazer um svn update.
att.

Em 25-08-2010 23:21, herbert em camaralencois.sp.gov.br escreveu:
> Certo Morale e qual a solução ???  a unica forma foi fazendo como o grande
> Luciano disse. ou tem que editar o banco e colocar um valor ????
>
>
> On Wed, 25 Aug 2010 16:55:53 -0300, Claudio Morale
> <claudiomorale em interlegis.gov.br>  wrote:
>> Luciano e colegas, isso está acontecendo somente na 1a.vez. Apesar de
>> auto_increment precisa de um valor inicial. Ao tentar obter o proximo
>> valor chave, o mysql não incrementa pq lá consta nulo.
>>
>> att.
>>
>>
>> Em 23-08-2010 21:17, Luciano De Fazio escreveu:
>>> Colegas,
>>>
>>> Para resolver o problema, pelo menos temporariamente:
>>>
>>> Faça uma cópia de segurança do
>>> arquivo
>>> $instance_home/skins/sk_sapl/zsql/composicao_comissao_incluir_zsql.zsql
>>>
>>> Depois, substitua pelo arquivo em anexo.
>>>
>>> Reinicie o Zope e tente novamente incluir a composição da comissão.
>>>
>>> O arquivo original chama o script
> composicao_comissao_obter_proximo_pysc.
>>> Ele está causando o erro.
>>>
>>> Não entendi porque dessa chamada, uma vez que o campo
>>> "cod_composicao_comissao", na tabela "composicao_comissao", já é
>>> auto_increment.
>>>
>>> Somente com o arquivo em anexo é que estou conseguindo incluir
>>> parlamentares
>>> nas comissões.
>>>
>>> []'s
>>>
>>> Luciano De Fázio
>>>
>>>
>>>
>>>
>>> Em 23 de agosto de 2010 16:57, Eduardo Vinicius
>>> <eduardovfsilva em gmail.com>escreveu:
>>>
>>>> Comigo acontece o mesmo erro.
>>>>
>>>> Estou utilizando SAPL versão: 2.3 e Ubuntu 10.04
>>>>
>>>> O endereço da página em que acontece o erro é
>>>>
>>>>
> http://127.0.0.1:8080/sapl/cadastros/comissao/composicao/composicao_comissao_form?nom_comissao=COMISS%C3O+DE+CONSTITUI%C7%C3O%2C+JUSTI%C7A+E+REDA%C7%C3O&cod_comissao=1&cod_periodo_comp=1&Submit=Incluir+Parlamentar+na+Composi%E7%E3o
>>>>
>>>> Uma imagem da tela:
>>>> http://img827.imageshack.us/f/addparlamentarcomissao.png/
>>>>
>>>> Em 23 de agosto de 2010 16:26,<herbert em camaralencois.sp.gov.br>
>>>> escreveu:
>>>>> da o seguinte erro quando eu vou adicionar um parlamentar nas
>>>>> comissões
>>>>>
>>>>> Zope Error
>>>>>
>>>>> Zope encontrou um erro ao publicar esta página.
>>>>>
>>>>> Tipo do Erro: TypeError
>>>>> Valor do Erro: int() argument must be a string or a number
>>>>>
>>>>> Pq isso ocorre ???  lembrando que este sapl que to fazendo é uma
>>>>> instancia...
>>>>>
>>>>>
>>>>> No aguardo ..........
>>>>> --
>>>>> Site da Comunidade GITEC:
>>>>> http://colab.interlegis.gov.br/wiki
>>>>>
>>>>> Regras de participação:
>>>>> http://colab.interlegis.gov.br/wiki/ComoParticiparComunidade
>>>>>
>>>>> Para pesquisar o histórico da lista visite:
>>>>> http://colab.interlegis.gov.br/wiki/PesquisaListas
>>>>>
>>>>> Para administrar sua conta visite:
>>>>> http://listas.interlegis.gov.br/mailman/listinfo/gitec
>>>>>
>>>> --
>>>> Site da Comunidade GITEC:
>>>> http://colab.interlegis.gov.br/wiki
>>>>
>>>> Regras de participação:
>>>> http://colab.interlegis.gov.br/wiki/ComoParticiparComunidade
>>>>
>>>> Para pesquisar o histórico da lista visite:
>>>> http://colab.interlegis.gov.br/wiki/PesquisaListas
>>>>
>>>> Para administrar sua conta visite:
>>>> http://listas.interlegis.gov.br/mailman/listinfo/gitec
>>>>
>>>
>>
>>
>> --
>> Claudio Morale
>> Analista de Sistemas
>> Interlegis - Brasília (DF)


-- 
Claudio Morale
Analista de Sistemas
Interlegis - Brasília (DF)


Mais detalhes sobre a lista de discussão GITEC