[gitec] conectar ao servidor

Márcio Vilas Boas marcio em camaradiv.mg.gov.br
Sexta Janeiro 9 19:00:32 BRST 2009


Olá André,

Realmente este problema persiste no 8.04.

Solução:
Estou migrando tudo para a 8.10.
Faço a conexão normalmente e adiciono em Marcadores.
Assim, os compartilhamentos ficam em Locais e também (claro!) em Marcadores.
Quando se clica em um mapeamento destes cria-se automaticamente um 
atalho no desktop do usuário.
Este atalho dura somente durante a sessão atual, mas continuam nos 
Marcadores ou em Locais mesmo reiniciando o sistema.

Outra alternativa é criar uma sessão para cada mapeamento mais ou menos 
assim:

sudo mount -t smbfs -o username=usuario,password=senha,iochasert=utf8 
//servidor/compartilhamento /ponto_de_montagem

Obs.: pode usar mount.cifs também no lugar de smbfs, em versões mais 
novas do ubuntu

Faço desta forma também em conjunto com a descrita acima, porque fiz um 
script de backup reverso(da rede para hd local) e preciso copiar de um 
ponto visível e fixo, uma vez que as montagens padrões ficam em .gvfs 
(gnome virtual file system).

Detalhe:
Para que a montagem possa ser feita por um usuário comum ( mount só pode 
ser executado como superusuário) é necessário editar o arquivo sudoers 
com sudo visudo e acrescentar as permissões de montagem e desmontagem 
para cada usuário para estes comandos.

Deu para entender? Se não, posso passar mais detalhes de como fazer.

bom fim de semana e até lá...

[],s

Márcio Vilas Boas
CM - Divinópolis - MG




Em 09-01-2009 16:24, André Brum da Silva escreveu:
> Pessoal,
>
> to com um problema aki para o qual não achei solução na lista, nem em
> lugar nenhum. Tal problema já foi relatado pelo Márcio, de Divinópolis,
> mas a solução que ele sugeriu não funcionou comigo. Ele relatou o
> seguinte, que é o meu caso também:
>
> "Encontrei um problema parecido no 8.04. Nossos linuxs conectam aos 
> compartilhamentos samba. Até o 7.10 era só ir em Locais, Conectar ao 
> Servidor e fazer a conexão desejada que um icone ia para o desktop. 
> Está  funcionando assim com todos ubuntus que temos(7.10).
> No 8.04, ao fazer esta mesma conexão, dá um erro de cara que "Não foi 
> possível achar o exibir localização "smb://servidor/compartilhamento/" 
> Nenhuma informação disponível."
> Deve se tratar de um bug porque mesmo assim, o compartilhamento é feito, 
> porém cria-se 2 ícones para cada um e, pior, quando a máquina é 
> reiniciada estes atalhos desaparecem. Também identifiquei que após algum 
> tempo estes para de funcionar.
> Um meio que encontrei para contornar isto é fazer um lançador apontando 
> para smb://servidor/compartilhamento ou na hora que for usar a opção de 
> conectar ao servidor, fazê-lo como Marcador. Assim não se perde.
> Antes do lançamento oficial, já tinha visto na internet alguém 
> comentando sobre este bug que ao meu ver ainda persiste ou então mudaram 
> a maneira de se fazer isto e não sabemos ainda.
> Os compartilhamentos tipo mount -t smbfs -o username= blablabla 
> funcionam tbem, mas é preciso colocá-los para iniciar com a sessão do user.
> Outra coisa, no 8.10 os compartilhamentos ficam em um diretório oculto 
> do usuário ( /home/user/.gvfs)
> Se alguém tiver um palpite dá um grito aí."
>
> Bem, reitero o pedido de palpite.
>
> André Brum
> Agudo RS
>
>   



More information about the GITEC mailing list