[Gitec] Re: banco Data.fs e backup

Paulo Fernandes de Souza Jr. paulofernandes at interlegis.gov.br
Mon May 23 15:07:48 BRT 2005


Alberto,

  Vamos voltar com o assunto para a lista, porque acho que é de
interesse de todos.


  Sem o wvware os documentos do MSWord não irão funcionar. Ou instale-o
(em um terminal, como root, digite apt-get install wv) ou anexe os
documentos em outro formato. 

  Já falamos sobre a cópia do Data.fs. Se copiar inteiro vai sobrepor a
versão 2.0 sobre a 2.0.2. Se copiar a pasta do SAPL também. O certo é
copiar apenas aquelas que o Luciano indicou. 

  A pesquisa básica é baseada nos dados do MySQL. Se não consegue fazer
é porque algo está errado na cópia do backup. Não há diferenças entre no
MySQL entre as versões 2.0 e 2.0.2. No servidor atual,  SRV06, a
pesquisa básica está funcionando.

Abraços, 

Paulo Fernandes.

Em Seg, 2005-05-23 às 14:20 -0300, Alberto escreveu:
> Paulo Fernandes,
> 
> Nos dois servidores o wvware não é encontrado somente
> o  xsltproc, o que tenho feito é isso mesmo copiado o
> Data.fs + backup e também já testei a importação da
> pasta SAPL para uma terceira máquina, indexei a pasta
> catalogo, depois fui pesquisar as normas juridicas,
> consegui apenas pesquisar através da pesquisa textual
> não fazendo a pesquisa básica.
> 
> alberto
> 
> 
> 
> 
> --- "Paulo Fernandes de Souza Jr."
> <paulofernandes at interlegis.gov.br> escreveu:
> 
> > 
> > 
> > Alberto,
> > 
> > 
> >   Eu entendi o que está acontecendo. E é justamente
> > isto que estou
> > pesquisando. Quando você anexa o texto de uma
> > norma-jurídica, o produto
> > que usamos para indexar transforma do formato
> > originas (doc, sxw, pdf,
> > txt ) para html. Ele usa produtos externos ao ZOPE
> > para isso. Talvez
> > estes produtos estejam instalados em um servidor e
> > no outro não. Por
> > isto pedi para você tentar salvar em outros
> > formatos. Pelo que vi
> > existem leis que estão com o texto integral
> > recentemente (17/05) como a
> > nº 1276 de 99. Elas foram anexadas ainda no servidor
> > antigo?
> > 
> >   
> >   Faça um teste: abra um terminal no servidor e
> > digite os seguintes
> > comandos: wvware e xsltproc . Veja se ele consegue
> > encontrar os
> > programas ou dá erro.
> > 
> >   O documento da Lei 46 eu não consegui anexá-lo
> > como .doc, na forma que
> > você me mandou. Ficou vazio na REG 9999 2005 que
> > criei para teste. Mas
> > salvei-o como PDF pelo OpenOffice e criei o REG 9998
> > 2005. Ele está lá
> > direitinho.
> > 
> >  O negócio da versão que aparece está estranho. O
> > número da versão fica
> > nas propriedades da pasta SAPL (veja na zmi). A
> > única forma de voltar
> > atrás é se você copia todo o Data.fs antigo por cima
> > do novo ou se
> > importar a pasta SAPL. Não é isto que está fazendo?
> > 
> > 
> > []s,
> > 
> > Paulo.
> > 
> >   
> > 
> > 
> > 
> > Em Seg, 2005-05-23 às 11:05 -0300, Alberto escreveu:
> > > Paulo,
> > > 
> > > 
> > > Vou te explicar mais detalhado para voce entender,
> > > eu tenho dois servidores instalados o SAPL um
> > > classifiquei de SRV08 o outro SRV06 porque um tem 
> > ip
> > > final 8 o outro 6 claro. Estamos trabalhando com o
> > > SRV08 alimentando tudo ok beleza, esse está ativo
> > só
> > > na intranet, o que fiz, instalei o sapl-2.0.2 no
> > SRV06
> > > onde vou disponibilizar para a internet porque ele
> > tem
> > > outras funcionalidades a mais, esse que você está
> > > acessando, acontece que quando levo o banco de
> > dados
> > > para o SRV06 ele não aceita anexar o texto
> > integral, e
> > > é os mesmos textos, com os mesmo formatos que
> > estamos
> > > incluindo no SVR08, fiz todo aqueles procedimento
> > que
> > > voce em enviou do export não deu certo, depois
> > veio o
> > > procedimento para copiar a pasta norma_juridica e
> > > acl_user, fiz a copia, mesmo assim tento inserir o
> > > texto integral e ele teima   em não aparecer. só
> > uma
> > > coisa estou incluindo pelo endereço interno da
> > rede
> > > será que pode ser isso e você fazendo pela
> > internet.
> > > Sem falar que depois na página principal do SAPL
> > > aparece e a versão 2.0 e não a 2.0.2, voce deve
> > ter
> > > visto isso ai acessando o nosso SAPL.
> > > Também quando levo o banco para a versão 2.0.2 a
> > opção
> > > do link para o texto integral, quando voce acessa
> > a
> > > ementa some. 
> > > 
> > > Alberto,
> > > 
> > > 
> > > 
> > > --- "Paulo Fernandes de Souza Jr."
> > > <paulofernandes at interlegis.gov.br> escreveu:
> > > 
> > > > Alberto,
> > > > 
> > > >   Acho que o problema é com o documento que você
> > > > está anexando. Mande-o
> > > > para mim por email para que possa testá-lo.
> > > > 
> > > > []s,
> > > > 
> > > > Paulo.
> > > > 
> > > > 
> > > > Em Sex, 2005-05-20 às 17:55 -0300, Alberto
> > escreveu:
> > > > > Paulo, também não estou entendendo, fiz um
> > teste
> > > > agora
> > > > > cadastrando essa lei 1101  ano 2005 anexei o
> > texto
> > > > > integral e depois da pesquisa clico em texto
> > > > integral
> > > > > e o texto não aparece.
> > > > > 
> > > > > alberto
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > --- "Paulo Fernandes de Souza Jr."
> > > > > <paulofernandes at interlegis.gov.br> escreveu:
> > > > > 
> > > > > > 
> > > > > >   Alberto, 
> > > > > > 
> > > > > >    Então não estou entendendo nada. Por aqui
> > eu
> > > > > > consigo fazer a pesquisa
> > > > > > básica e a textual, e também consigo inserir
> > > > tudo
> > > > > > normalmente, tudo isto
> > > > > > no endereço que você me passou. Tem apenas
> > um
> > > > > > problema na pesquisa
> > > > > > textual, quando você regerou o catálogo
> > > > > > provavelmente estava acessando o
> > > > > > sistema com o endereço interno, ip
> > 192.168.1.6,
> > > > e aí
> > > > > > ele guardou este
> > > > > > endereço no catálogo, no lugar de
> > > > > > www.aleac.ac.gov.br. Quando eu tento
> > > > > > abrir o link para o texto daqui ele não
> > > > funciona,
> > > > > > mas é só regerar o
> > > > > > catálogo com o endereço certo.
> > > > > > 
> > > > > > []s,
> > > > > > 
> > > > > > Paulo.
> > > > > >    
> > > > > >   
> > > > > > 
> > > > > > 
> > > > > > 
> > > > > > 
> > > > > > Em Sex, 2005-05-20 às 17:25 -0300, Alberto
> > > > escreveu:
> > > > > > > Sim, Paulo, fiz aqueles procedimentos de
> > > > copiar a
> > > > > > > pasta norma_juridica, fiz a indexação, só
> > que
> > > > na
> > > > > > hora
> > > > > > > da pesquisa, não faz pesquisa basica
> > apenas
> > > > > > pesquisa
> > > > > > > textual, aparecendo apenas o link do texto
> > > > > > integral.
> > > > > > > 
> > > > > > > As pessoas estão com perfil de operador de
> > > > norma.
> > > > > > > 
> > > > > > > alberto
> > > > > > > 
> > > > > > > 
> > > > > > > 
> > > > > > > 
> > > > > > > --- "Paulo Fernandes de Souza Jr."
> > > > > > > <paulofernandes at interlegis.gov.br>
> > escreveu:
> > > > > > > > Acabei de fazer um teste neste servidor
> > e
> > > > > > consegui
> > > > > > > > incluir uma norma um
> > > > > > > > arquivo txt de texto integral. Ficou
> > tudo
> > > > ok.
> > > > > > > > 
> > > > > > > > As pessoas que estão cadastrando as
> > normas
> > > > estão
> > > > > > com
> > > > > > > > o perfil de
> > > > > > > > operador norma , ou só o de operador???
> > > > > > > > 
> > > > > > > > []s,
> > > > > > > > 
> > > > > > > > Paulo.
> > > > > > > > 
> > > > > > > > 
> > > > > > > > Em Sex, 2005-05-20 às 15:37 -0300,
> > Alberto
> > > > > > escreveu:
> > > > > > > > > Paulo,
> > > > > > > > > É justamente para essa máquina que vc
> > esta
> > > > > > > > acessando
> > > > > > > > > pelo endereço
> > > > www.aleac.ac.gov.br:8080/sapl
> > > > > > que eu
> > > > > > > > > quero fazer a migração. O banco estou
> > > > > > alimentado
> > > > > > > > em
> > > > > > > > > outro servidor que não é muito bom, e
> > com
> > > > > > pouca
> > > > > > > > > capacidade. Vamos ao problema:
> > > > > > > > > 
> > > > > > > > > 1- Instalo o SAPL 2.0.2 nesse servidor
> > que
> > > > vc
> > > > > > está
> > > > > > > > > acessando.
> > > > > > > > > 2- Quando levo o Data.fs e backup para
> > > > esse
> > > > > > > > servidor
> > > > > > > > > ele sobrepõe a versão do SAPL 2.0.2
> > para
> > > > 2.0,
> > > > > > > > mesmo
> > > > > > > > > assim fica funcionando tudo direitinho
> > nas
> > > > > > > > pesquisas,
> > > > > > > > > o problena é na inclusão de novas leis
> > > > quando
> > > > > > > > > anexamos, o texto integral não
> > aparece. O
> > > > link
> > > > > > do
> > > > > > > > > texto integral na ementa também some,
> > > > > > resultado
> > > > > > > > não
> > > > > > > > > conseguimos trabalhar nesse servidor.
> > > > > > > > > 3- Já instalei o SAPL 2.0.2 em outras
> > > > maquinas
> > > > > > > > para
> > > > > > > > > teste e acontece a mesma coisa, pensei
> > que
> > > > > > seria
> > > > > > > > por
> > > > > > > > > ter atualizado o cl10, mais não,
> > peguei um
> > > > > > maquina
> > > > > > > > > formatei instalei o cl10, instalei o
> > sapl,
> > > > > > > > restaurei o
> > > > > > > > > banco e o backup, e deu o mesmo
> > problema.
> > > > > > > > > 
> > > > > > > > > Alberto
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > --- "Paulo Fernandes de Souza Jr."
> > > > > > > > > <paulofernandes at interlegis.gov.br>
> > > > escreveu:
> > > > > > > > > > Alberto,
> > > > > > > > > > 
> > > > > > > > > >   Qual o endereço do servidor de
> > vocês.
> > > > > > Estou
> > > > > > > > > > entrando em
> > > > > > > > > > http://aleac.ac.gov.br:8080/sapl , e
> > > > todas
> > > > > > as
> > > > > > > > > > pesquisas funcionam ok.
> > > > > > > > > > 
> > > > > > > > > > []s,
> > > > > > > > > > 
> > > > > > > > > > Paulo Fernandes.
> > > > > > > > > > 



Mais detalhes sobre a lista de discussão Gitec