[Gitec] Senha do Zope

Luciano De Fázio luciano at camaracatanduva.sp.gov.br
Wed Oct 27 14:27:44 BRST 2004


Cristiano,

Algumas alternativas que podem ocasionar o erro:

- pode haver algum processo ativo do servidor Zope - verifique com o 
comando "ps aux" e veja se há algum processo cujo dono seja zopesapl / 
zopeadm ou netstat -at (procurando pela porta 8080). Você tambpem pode 
verificar o conteúdo dos arquivos Z2.pid e Z2.lock, que possuem o número 
do processo ativo-  Nesta caso, mate o processo / pare o servidor e 
reinicie manualmente.

- o usuário do sistema (zopesapl / zopeadm ) responsável por "rodar" o 
Zope pode não ter permissão de leitura e escrita dentro do diretório 
"var" - neste caso dê permissões para o usuário: "chown 
zopesapl:zopesapl -R var" (verifique o usuário correto)

Qual é mesmo a versão de seu SAPL ?

Abraço,

Luciano De Fázio
Coordenador de Informática e Tecnologia
Câmara Municipal de Catanduva - SP



C.P.D. - Câmara Municipal de Timóteo escreveu:

>Boa tarde!!
>
>Peço desculpas mas ainda tenho problemas em relação ao senha do zope.
>
>Em primeiro lugar fiz o que o Ton ensinou, não sei o que eu fiz de errado
>mas meu zope não rodava. Então vendo o email do Luciano segui os passos
>dele. Agora qdo tento startar o zope recebo as seguintes mensagens:
>
>------
>2004-10-27T12:54:51 INFO(0) zdaemon Started subprocess: pid 1530
>------
>2004-10-27T12:54:54 PANIC(300) z2 Startup exception
>Traceback (innermost last):
>  Module __main__, line 580, in ?
>  Module <string>, line 1, in ?
>  Module Zope, line 37, in ?
>  Module ZODB.FileStorage, line 220, in __init__
>  Module ZODB.lock_file, line 33, in lock_file
>StorageSystemError: Could not lock the database file. There must be
>another process that has opened the file.
><p>
>
>Desculpem o incomodo mas sabem o que eu posso fazer?
>
>Obrigado,
>
>Cristiano
>Camara de Timóteo - MG
>  
>


Mais detalhes sobre a lista de discussão Gitec