[Gitec] problemas com buscas

Luciano De Fázio luciano em camaracatanduva.sp.gov.br
Sexta Junho 25 14:05:55 BRT 2004


Caro Maurício:

Este problema é relativo ao banco de dados MySQL, e não ao Zope.

Tivemos o mesmo problema há algum tempo atrás, aqui em Catanduva, e 
parece estar relacionado com inicialização manual do MySQL ou através do 
arquivo rc.local.

Tente proceder da seguinte forma:

Coloque o MySQL em inicialização automática. No console, como usuário 
root, digite:

# ntsysv

Aparecerá uma lista de programas, marque com "X"o item "mysql".

Selecione OK e saia. Em seguida reinicie a máquina; o MySQL deverá 
inicializar automaticamente.

Para verificar se o serviço está rodando, digite: # service mysql status.

--

Se a opção mysql não constar da lista de aplicativos do ntsysv, inclua-o 
dessa forma:

# cds

# chkconfig --add mysql

E configure o serviço para inicialização automática.

Abraço,


Luciano De Fázio
Coordenador de Informática e Tecnologia
Câmara Municipal de Catanduva - SP




Mauricio Diniz escreveu:

>Estou fazendo alguns testes.
>Ja cadastrei varias informacoes e tudo parece estar ok. 
>So que quando faco qualquer tipo de busca (Normas Juridicas e Materias
>Legislativas) obtenho o erro:
>
>Zope encontrou um erro ao publicar esta página.
>
>Tipo do Erro: InternalError
>Valor do Erro: (1, "Can't create/write to file
>'/root/tmp/#sql_431_0.MYI' (Errcode: 13)")
>
>Movi o arquivo Data.fs da maquina que esta com o problema para uma nova
>que nao apresentava o referido problema, depois da mudanca as duas
>maquinas apresentaram o mesmo problema.
> 
>
>Se tiverem sugestoes...!
>
>_______________________________________________
>Gitec mailing list
>Gitec em listas.interlegis.gov.br
>http://listas.interlegis.gov.br/mailman/listinfo/gitec
>  
>



Mais detalhes sobre a lista de discussão Gitec